summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-09 11:50:00 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-09 13:31:40 +0200
commit78d3baee6a4c834139f8030a632e31db75cab0c6 (patch)
tree97353bfd1f6a7a440e3975e56e8b4ed8e8a01c26 /kde-frameworks/frameworkintegration
parentapp-text/libmspub: Fix build with GCC 10, EAPI-7 bump (diff)
downloadgentoo-78d3baee6a4c834139f8030a632e31db75cab0c6.tar.gz
gentoo-78d3baee6a4c834139f8030a632e31db75cab0c6.tar.bz2
gentoo-78d3baee6a4c834139f8030a632e31db75cab0c6.zip
kde-frameworks: Add KDE Frameworks 5.70.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.70.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 333cb83115da..b753f3b32bc2 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.67.0.tar.xz 1753624 BLAKE2B cf70bed5acf65240568aafe7b025db339550abc0226d1f560d24636e4368955028148d9dbdf47afbe2e0f98850c9112aaf7ffc02966ffb48e27814adfc7cb65c SHA512 47ec7ebc2b1067074620a5a9e39f5aa664595569fc2d4a1c591e34e9ac52502fffd51f7707a522bf4028f50064f82dfafe2c6b46faa3b0f212b766e6f2ac2186
DIST frameworkintegration-5.69.0.tar.xz 1754048 BLAKE2B 8809b3cdf5f2c61d4370266b12c50bb0673ea4a83c8677d44a9d510392e5ddc5b8f2e77e4bd70d5b2de62753dc8661d3f4dd5995bea73f77f59198349715f0e4 SHA512 2c217182a083cc7adde2460716e4ee8cb02a1583d002b5fdbd1e3a570e92ee8faf8fc6520f8debccf3dc8fc143352379054b7a15fad05c21cd658969c5bfdf17
+DIST frameworkintegration-5.70.0.tar.xz 1753940 BLAKE2B 5da86d4b7fe8a696e217273ff468c668ec1e04c138dd756a0a9280fbd6acb99f9cbd3bbce1790886de50335d036e7a99a83f1ea4ad4103101ecc46878d0e071b SHA512 70a72388315c0ca1625bb279b15a9df1693aed9a6dd470af8744b856e5c7cc458b0ffcc384489889e8c3e753edb03062b41cc688361498e45ac3a26d7be70a34
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.70.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.70.0.ebuild
new file mode 100644
index 000000000000..a4bb90f9557a
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.70.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.12.3
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+# drop qtwidgets subslot operator when QT_MINIMAL >= 5.14.0
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5=
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+# requires running Plasma environment
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}