summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-04-15 20:25:47 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-04-15 20:27:00 +0200
commit4ab71f2653b05f6f08d5fee913c5d0c3db2d195c (patch)
treeea635626b36af702091f1a035493811e40efaf1c /kde-frameworks/plasma
parentdev-python/jmespath: Stabilize 1.0.0 ALLARCHES, #838613 (diff)
downloadgentoo-4ab71f2653b05f6f08d5fee913c5d0c3db2d195c.tar.gz
gentoo-4ab71f2653b05f6f08d5fee913c5d0c3db2d195c.tar.bz2
gentoo-4ab71f2653b05f6f08d5fee913c5d0c3db2d195c.zip
kde-frameworks/plasma: Dialog: Do not upd. layout params while hidden
See also: https://mail.kde.org/pipermail/distributions/2022-April/001216.html KDE-bug: https://bugs.kde.org/show_bug.cgi?id=452512 Upstream commit b62d83bef7733e4943e6f66787166b41198d1359 Closes: https://bugs.gentoo.org/838661 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/plasma')
-rw-r--r--kde-frameworks/plasma/files/plasma-5.93.0-fix-widget-popups.patch29
-rw-r--r--kde-frameworks/plasma/plasma-5.93.0-r1.ebuild (renamed from kde-frameworks/plasma/plasma-5.93.0.ebuild)5
2 files changed, 33 insertions, 1 deletions
diff --git a/kde-frameworks/plasma/files/plasma-5.93.0-fix-widget-popups.patch b/kde-frameworks/plasma/files/plasma-5.93.0-fix-widget-popups.patch
new file mode 100644
index 000000000000..7f95c6531a95
--- /dev/null
+++ b/kde-frameworks/plasma/files/plasma-5.93.0-fix-widget-popups.patch
@@ -0,0 +1,29 @@
+From b62d83bef7733e4943e6f66787166b41198d1359 Mon Sep 17 00:00:00 2001
+From: Aleix Pol <aleixpol@kde.org>
+Date: Wed, 13 Apr 2022 16:05:32 +0200
+Subject: [PATCH] Dialog: Do not update layout parameters while hidden
+
+Wait until the dialog it's shown to position the components within.
+Otherwise we do it based on a random size.
+
+BUG: 452512
+---
+ src/plasmaquick/dialog.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/plasmaquick/dialog.cpp b/src/plasmaquick/dialog.cpp
+index 09937ef0f..9ca2c8a66 100644
+--- a/src/plasmaquick/dialog.cpp
++++ b/src/plasmaquick/dialog.cpp
+@@ -475,7 +475,7 @@ void DialogPrivate::getSizeHints(QSize &min, QSize &max) const
+
+ void DialogPrivate::updateLayoutParameters()
+ {
+- if (!componentComplete || !mainItem || !mainItemLayout) {
++ if (!componentComplete || !mainItem || !mainItemLayout || q->visibility() == QWindow::Hidden) {
+ return;
+ }
+
+--
+GitLab
+
diff --git a/kde-frameworks/plasma/plasma-5.93.0.ebuild b/kde-frameworks/plasma/plasma-5.93.0-r1.ebuild
index 8203773544a2..1548d3671d1d 100644
--- a/kde-frameworks/plasma/plasma-5.93.0.ebuild
+++ b/kde-frameworks/plasma/plasma-5.93.0-r1.ebuild
@@ -59,7 +59,10 @@ DEPEND="${RDEPEND}
"
BDEPEND="man? ( >=kde-frameworks/kdoctools-${PVCUT}:5 )"
-PATCHES=( "${FILESDIR}/${PN}-5.92.0-fix-blurry-buttons.patch" ) # KDE-bug 447977
+PATCHES=(
+ "${FILESDIR}/${PN}-5.92.0-fix-blurry-buttons.patch" # KDE-bug 447977
+ "${FILESDIR}/${P}-fix-widget-popups.patch" # bug 838661, KDE-bug 452512
+)
src_configure() {
local mycmakeargs=(