summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-15 12:12:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-15 13:58:34 +0100
commitb5f0806e00fadca2d0c9819e9ab46b0d4c2da58f (patch)
tree651d11303c1a4fdb7aae0dd382ce043ffb840404 /kde-frameworks/prison
parentapp-emulation/qemu: bump up to 4.2.0, bug #702036 (diff)
downloadgentoo-b5f0806e00fadca2d0c9819e9ab46b0d4c2da58f.tar.gz
gentoo-b5f0806e00fadca2d0c9819e9ab46b0d4c2da58f.tar.bz2
gentoo-b5f0806e00fadca2d0c9819e9ab46b0d4c2da58f.zip
kde-frameworks: Add KDE Frameworks 5.65
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/prison')
-rw-r--r--kde-frameworks/prison/Manifest1
-rw-r--r--kde-frameworks/prison/prison-5.65.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/kde-frameworks/prison/Manifest b/kde-frameworks/prison/Manifest
index 646f9fd1539a..6ca881cefd97 100644
--- a/kde-frameworks/prison/Manifest
+++ b/kde-frameworks/prison/Manifest
@@ -1 +1,2 @@
DIST prison-5.64.0.tar.xz 42116 BLAKE2B 4e70cdfef7f7e44566d842a533094978e68bba7b658fe57da818ed84b90ceec97e601d525af96989b171c45453bec45a0bab20daee12bde18dc55c41349c7513 SHA512 d8d19d9756d1b46a3fd1d94676730054c79fe01c6990f4ff059154d5ff6cbf20e357ae79784e4f1cc621352017dc3f3b56f309f9b5363bf6d0dab39912c6e930
+DIST prison-5.65.0.tar.xz 42040 BLAKE2B 4804de2121a40bf1628bcfae734781a8e339d1720cd15b794601402b50d39df623c51150bc6edf6cfc01dbb5256cae209de2268794582f8fbeabafc576f0355a SHA512 90840044073a2a2b6c3e6540ee0ca7b06ddcfbc13ed332590fca087cb0d78f660b0163ffd74d7b332ae99e07faa6417bcc3aa1b5a503246b501363f3738b7ce8
diff --git a/kde-frameworks/prison/prison-5.65.0.ebuild b/kde-frameworks/prison/prison-5.65.0.ebuild
new file mode 100644
index 000000000000..f39dea32048b
--- /dev/null
+++ b/kde-frameworks/prison/prison-5.65.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="QRCode and data matrix barcode library"
+HOMEPAGE="https://cgit.kde.org/prison.git"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="qml"
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ media-gfx/qrencode:=
+ media-libs/libdmtx
+ qml? ( >=dev-qt/qtdeclarative-${QTMIN}:5 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package qml Qt5Quick)
+ )
+
+ ecm_src_configure
+}