summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-09-04 13:09:00 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-04 22:58:43 +0200
commit2a33f82ee80caa693a8a22b30667f42c89aaa929 (patch)
tree04a4e85d529420b7dbd788375e1d7b6180bfb2f2 /kde-frameworks
parentkde-frameworks/syntax-highlighting: Drop 5.85.0 (r0) (diff)
downloadgentoo-2a33f82ee80caa693a8a22b30667f42c89aaa929.tar.gz
gentoo-2a33f82ee80caa693a8a22b30667f42c89aaa929.tar.bz2
gentoo-2a33f82ee80caa693a8a22b30667f42c89aaa929.zip
kde-frameworks/plasma: ExpandableListItem: Fix overlapping entries
Upstream commit f393bace87e5fc8c0e68eff9faf0656df64715ed KDE-bug: https://bugs.kde.org/show_bug.cgi?id=428102 Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/plasma/files/plasma-5.85.0-fix-ExpandableListItem-overlapping.patch41
-rw-r--r--kde-frameworks/plasma/plasma-5.85.0-r3.ebuild80
2 files changed, 121 insertions, 0 deletions
diff --git a/kde-frameworks/plasma/files/plasma-5.85.0-fix-ExpandableListItem-overlapping.patch b/kde-frameworks/plasma/files/plasma-5.85.0-fix-ExpandableListItem-overlapping.patch
new file mode 100644
index 000000000000..8063039b7626
--- /dev/null
+++ b/kde-frameworks/plasma/files/plasma-5.85.0-fix-ExpandableListItem-overlapping.patch
@@ -0,0 +1,41 @@
+From f393bace87e5fc8c0e68eff9faf0656df64715ed Mon Sep 17 00:00:00 2001
+From: Nate Graham <nate@kde.org>
+Date: Wed, 1 Sep 2021 12:30:01 -0600
+Subject: [PATCH] ExpandableListItem: Fix overlapping entries with many
+ expanded items
+
+A previous hack was done wrong, and was not taking into account disabled
+items.
+
+BUG: 428102
+FIXED-IN: 5.86
+---
+ .../plasmaextracomponents/qml/ExpandableListItem.qml | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/src/declarativeimports/plasmaextracomponents/qml/ExpandableListItem.qml b/src/declarativeimports/plasmaextracomponents/qml/ExpandableListItem.qml
+index 47b3e3684..851961a4c 100644
+--- a/src/declarativeimports/plasmaextracomponents/qml/ExpandableListItem.qml
++++ b/src/declarativeimports/plasmaextracomponents/qml/ExpandableListItem.qml
+@@ -523,7 +523,7 @@ Item {
+
+ // Container for actions list, so that we can add left and right margins to it
+ Item {
+- height: actionsList.contentHeight
++ height: actionsList.height
+ width: mainRowLayout.width
+
+ // TODO: Implement keyboard focus
+@@ -538,7 +538,8 @@ Item {
+ anchors.leftMargin: listItemIcon.width + PlasmaCore.Units.smallSpacing
+ anchors.rightMargin: listItemIcon.width + PlasmaCore.Units.smallSpacing * 2
+
+- height: PlasmaCore.Units.gridUnit * 2 * actionsList.count
++ // Need to take into account disabled/invisible items
++ height: PlasmaCore.Units.gridUnit * 2 * Array.from(contextualActionsModel).filter(item => item.enabled).length
+
+ focus: true
+ clip: true
+--
+GitLab
+
diff --git a/kde-frameworks/plasma/plasma-5.85.0-r3.ebuild b/kde-frameworks/plasma/plasma-5.85.0-r3.ebuild
new file mode 100644
index 000000000000..433fe380d175
--- /dev/null
+++ b/kde-frameworks/plasma/plasma-5.85.0-r3.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_ORG_NAME="${PN}-framework"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Plasma framework"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="gles2-only man wayland X"
+
+RESTRICT+=" test"
+
+RDEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5[gles2-only=,X=]
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtsql-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kactivities-${PVCUT}*:5
+ =kde-frameworks/karchive-${PVCUT}*:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kdeclarative-${PVCUT}*:5
+ =kde-frameworks/kglobalaccel-${PVCUT}*:5
+ =kde-frameworks/kguiaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5
+ =kde-frameworks/kxmlgui-${PVCUT}*:5
+ !gles2-only? ( media-libs/libglvnd[X?] )
+ wayland? (
+ =kde-frameworks/kwayland-${PVCUT}*:5
+ media-libs/libglvnd
+ )
+ X? (
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ x11-libs/libX11
+ x11-libs/libxcb
+ )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+BDEPEND="man? ( >=kde-frameworks/kdoctools-${PVCUT}:5 )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-plasma-scaling-w-int-scale-factors.patch
+ "${FILESDIR}"/${P}-fix-pinned-calendar-dots.patch # KDE-bug 440627
+ "${FILESDIR}"/${P}-fix-cmake.patch # bug 809815
+ "${FILESDIR}"/${P}-fix-ExpandableListItem-overlapping.patch # KDE-bug 428102
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package !gles2-only OpenGL)
+ $(cmake_use_find_package man KF5DocTools)
+ $(cmake_use_find_package wayland EGL)
+ $(cmake_use_find_package wayland KF5Wayland)
+ $(cmake_use_find_package X X11)
+ $(cmake_use_find_package X XCB)
+ )
+
+ ecm_src_configure
+}