summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-06-20 00:06:06 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-06-20 00:06:24 +1000
commit53815d0e6783e561151d642198c3cdd1eec364e7 (patch)
tree12f46186298e08d40bb6d6afaf88025509c54b97 /kde-frameworks
parentnet-im/openfire: fix typo 's/dir/die/' (diff)
downloadgentoo-53815d0e6783e561151d642198c3cdd1eec364e7.tar.gz
gentoo-53815d0e6783e561151d642198c3cdd1eec364e7.tar.bz2
gentoo-53815d0e6783e561151d642198c3cdd1eec364e7.zip
kde-frameworks/kauth: revision bump to add Qt subslot operator
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/kauth/kauth-5.23.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-frameworks/kauth/kauth-5.23.0-r1.ebuild b/kde-frameworks/kauth/kauth-5.23.0-r1.ebuild
new file mode 100644
index 000000000000..619bed0d5246
--- /dev/null
+++ b/kde-frameworks/kauth/kauth-5.23.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework to let applications perform actions as a privileged user"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="nls +policykit"
+
+# drop qtgui subslot operator when QT_MINIMAL >= 5.7.0
+RDEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui '' '' '5=')
+ $(add_qt_dep qtwidgets)
+ policykit? ( sys-auth/polkit-qt[qt5] )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+PDEPEND="policykit? ( kde-plasma/polkit-kde-agent )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package policykit PolkitQt5-1)
+ )
+
+ kde5_src_configure
+}