summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-02-12 10:59:00 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-02-12 12:09:43 +0100
commiteced9acd8777c0d327428441c4e9c838602b4635 (patch)
tree04fc3be5b783883a966dc7002bf0734f8ee50c1f /kde-frameworks
parentkde-frameworks/solid: 5.103.0 version bump (diff)
downloadgentoo-eced9acd8777c0d327428441c4e9c838602b4635.tar.gz
gentoo-eced9acd8777c0d327428441c4e9c838602b4635.tar.bz2
gentoo-eced9acd8777c0d327428441c4e9c838602b4635.zip
kde-frameworks/sonnet: 5.103.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/sonnet/Manifest1
-rw-r--r--kde-frameworks/sonnet/sonnet-5.103.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/Manifest b/kde-frameworks/sonnet/Manifest
index 13111b525af9..220a337021af 100644
--- a/kde-frameworks/sonnet/Manifest
+++ b/kde-frameworks/sonnet/Manifest
@@ -1,2 +1,3 @@
DIST sonnet-5.102.0.tar.xz 2437512 BLAKE2B 21ec1843a3b5757b6dcdae154248d3b2cd3fe7aed80e83e746a5a63beb07b828d234fdcd28f69cfa56f250d781552fc3cc544f708b9ea3cabb530feb3126676b SHA512 85bd83954247b5d676b63cf7333e18d936b471138da7509a642e06074ba936dbb0b07723bdacc8d1508b05ffe84748585e98a34bae76836a6378e4c42a58800e
+DIST sonnet-5.103.0.tar.xz 2437700 BLAKE2B b90687611856f6efb73e14169ac518d01e031d599bef9fa2522a27b53bf9a10e003b44ab5f5d635b8d62a6e4fc3716176bd66bf8f9e769aaf49f59709a992406 SHA512 29e5e45ee651564e1870e7d8e94943f47232eacb659444b0ebfd4adee066af9a09dff9f7f75edd21e8de4a57753031c54cb9e934dc157c060646b6f275b3bdf2
DIST sonnet-5.99.0.tar.xz 307868 BLAKE2B 43591a0bd09f88b745b8577a8ac38b6fc1a60a20f97e2d35de19072f7956fd31974d35ebdbd3a802b4b0c7c63bfdacc214314e43dc3d0655c59a9df4236df6a1 SHA512 781e96a9ff4363dd4bc2a95f6fadcd97991cbcd4781314f082297544c4da38c57fa62c4aec62d8cf850c5d8147e0b30f6835d143a691ea293100c00511ab318b
diff --git a/kde-frameworks/sonnet/sonnet-5.103.0.ebuild b/kde-frameworks/sonnet/sonnet-5.103.0.ebuild
new file mode 100644
index 000000000000..7a7c5fa14e02
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.103.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_DESIGNERPLUGIN="true"
+QTMIN=5.15.5
+VIRTUALX_REQUIRED="test"
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
+
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="aspell +hunspell qml"
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell:= )
+ qml? ( >=dev-qt/qtdeclarative-${QTMIN}:5 )
+"
+RDEPEND="${DEPEND}"
+BDEPEND=">=dev-qt/linguist-tools-${QTMIN}:5"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package aspell ASPELL)
+ $(cmake_use_find_package hunspell HUNSPELL)
+ -DSONNET_USE_QML=$(usex qml)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # sonnet-test_settings: bug 680032
+ # sonnet-test_autodetect: bug 779994
+ local myctestargs=(
+ -E "(sonnet-test_autodetect|sonnet-test_settings|sonnet-test_highlighter)"
+ )
+
+ ecm_src_test
+}