summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTill Schäfer <till2.schaefer@uni-dortmund.de>2018-01-16 21:33:44 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-01-19 16:33:12 +0100
commit4050252b0cf86ec4f9c23862875bd245907aa9e2 (patch)
treef92dc035ec9ca01c6f2a1d0c61a0f36f50230bd7 /kde-misc/playbar2/playbar2-2.5.ebuild
parentnet-analyzer/prometheus: Version bump to 2.1.0 (diff)
downloadgentoo-4050252b0cf86ec4f9c23862875bd245907aa9e2.tar.gz
gentoo-4050252b0cf86ec4f9c23862875bd245907aa9e2.tar.bz2
gentoo-4050252b0cf86ec4f9c23862875bd245907aa9e2.zip
kde-misc/playbar2: New package
Package-Manager: Portage-2.3.19, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/6883
Diffstat (limited to 'kde-misc/playbar2/playbar2-2.5.ebuild')
-rw-r--r--kde-misc/playbar2/playbar2-2.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-misc/playbar2/playbar2-2.5.ebuild b/kde-misc/playbar2/playbar2-2.5.ebuild
new file mode 100644
index 000000000000..5b2b272acd93
--- /dev/null
+++ b/kde-misc/playbar2/playbar2-2.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kde5-functions
+
+DESCRIPTION="MPRIS2 client, written in QML for Plasma 5"
+HOMEPAGE="https://github.com/audoban/PlayBar2"
+SRC_URI="https://github.com/audoban/PlayBar2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="$(add_frameworks_dep extra-cmake-modules)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdoctools)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep plasma)
+ $(add_qt_dep qtcore)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtquickcontrols)
+ $(add_qt_dep qtwidgets)"
+RDEPEND="${DEPEND}"