summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-04-03 16:43:20 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-04-03 16:56:42 +0200
commit47b84fce9beb134c4584cf12e90a7a69f39eceb8 (patch)
treee3c7b82c0dbd39ddb6aac4df4cbb377e06cce878 /kde-plasma/breeze-plymouth/breeze-plymouth-5.18.4.1.ebuild
parentdev-lang/python: ignore EPERM in test.support.unlink() (diff)
downloadgentoo-47b84fce9beb134c4584cf12e90a7a69f39eceb8.tar.gz
gentoo-47b84fce9beb134c4584cf12e90a7a69f39eceb8.tar.bz2
gentoo-47b84fce9beb134c4584cf12e90a7a69f39eceb8.zip
kde-plasma: Add KDE Plasma 5.18.4.1
Closes: https://bugs.gentoo.org/715884 Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/breeze-plymouth/breeze-plymouth-5.18.4.1.ebuild')
-rw-r--r--kde-plasma/breeze-plymouth/breeze-plymouth-5.18.4.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/kde-plasma/breeze-plymouth/breeze-plymouth-5.18.4.1.ebuild b/kde-plasma/breeze-plymouth/breeze-plymouth-5.18.4.1.ebuild
new file mode 100644
index 000000000000..9ac3d9978b8f
--- /dev/null
+++ b/kde-plasma/breeze-plymouth/breeze-plymouth-5.18.4.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.66.0
+PVCUT=$(ver_cut 1-3)
+inherit cmake kde.org
+
+DESCRIPTION="Breeze theme for Plymouth"
+
+LICENSE="GPL-2+ GPL-3+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+BDEPEND=">=kde-frameworks/extra-cmake-modules-${KFMIN}:5"
+DEPEND="sys-boot/plymouth"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISTRO_NAME="Gentoo Linux"
+ -DDISTRO_VERSION=
+ )
+
+ cmake_src_configure
+}