summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-07-07 22:42:01 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-07-07 23:29:53 +0200
commit155c1e70ae90b05fe41fcacf87326691e1e0e830 (patch)
tree8869f41b68d508b0095a77bdd64f6f0d60ea7d47 /kde-plasma/breeze-plymouth/breeze-plymouth-5.19.3.ebuild
parentkde-plasma/breeze-gtk: 5.19.3 version bump (diff)
downloadgentoo-155c1e70ae90b05fe41fcacf87326691e1e0e830.tar.gz
gentoo-155c1e70ae90b05fe41fcacf87326691e1e0e830.tar.bz2
gentoo-155c1e70ae90b05fe41fcacf87326691e1e0e830.zip
kde-plasma/breeze-plymouth: 5.19.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/breeze-plymouth/breeze-plymouth-5.19.3.ebuild')
-rw-r--r--kde-plasma/breeze-plymouth/breeze-plymouth-5.19.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/kde-plasma/breeze-plymouth/breeze-plymouth-5.19.3.ebuild b/kde-plasma/breeze-plymouth/breeze-plymouth-5.19.3.ebuild
new file mode 100644
index 000000000000..5b9bdb606fd1
--- /dev/null
+++ b/kde-plasma/breeze-plymouth/breeze-plymouth-5.19.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.71.0
+PVCUT=$(ver_cut 1-3)
+inherit cmake kde.org
+
+DESCRIPTION="Breeze theme for Plymouth"
+
+LICENSE="GPL-2+ GPL-3+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+BDEPEND=">=kde-frameworks/extra-cmake-modules-${KFMIN}:5"
+DEPEND="sys-boot/plymouth"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISTRO_NAME="Gentoo Linux"
+ -DDISTRO_VERSION=
+ )
+
+ cmake_src_configure
+}