summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-12-16 01:14:15 +1100
committerMichael Palimaka <kensington@gentoo.org>2015-12-16 02:31:23 +1100
commite3eeda55533ee0564c283466854c25eab97a1678 (patch)
tree1b471207f3edb955d2145cdadaae6566cae419fc /kde-plasma/kde-gtk-config/kde-gtk-config-5.5.1.ebuild
parentdev-db/percona-server: Fix ebuild tests wrt bug 568328 (diff)
downloadgentoo-e3eeda55533ee0564c283466854c25eab97a1678.tar.gz
gentoo-e3eeda55533ee0564c283466854c25eab97a1678.tar.bz2
gentoo-e3eeda55533ee0564c283466854c25eab97a1678.zip
kde-plasma: version bump 5.5.1
Package-Manager: portage-2.2.26
Diffstat (limited to 'kde-plasma/kde-gtk-config/kde-gtk-config-5.5.1.ebuild')
-rw-r--r--kde-plasma/kde-gtk-config/kde-gtk-config-5.5.1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/kde-plasma/kde-gtk-config/kde-gtk-config-5.5.1.ebuild b/kde-plasma/kde-gtk-config/kde-gtk-config-5.5.1.ebuild
new file mode 100644
index 000000000000..dd38b01901e6
--- /dev/null
+++ b/kde-plasma/kde-gtk-config/kde-gtk-config-5.5.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE systemsettings kcm to set GTK application look&feel"
+HOMEPAGE="https://projects.kde.org/kde-gtk-config"
+LICENSE="GPL-3"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="+gtk3"
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kwidgetsaddons)
+ dev-libs/glib:2
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ x11-libs/gtk+:2
+ gtk3? ( x11-libs/gtk+:3 )
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !kde-base/kde-gtk-config:4
+ !kde-misc/kde-gtk-config
+"
+
+PATCHES=( "${FILESDIR}/${PN}-5.4.2-gtk3-optional.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DDATA_INSTALL_DIR="${EPREFIX}/usr/share"
+ -DBUILD_gtk3proxies=$(usex gtk3)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ einfo
+ elog "If you notice missing icons in your GTK applications, you may have to install"
+ elog "the corresponding themes for GTK. A good guess would be x11-themes/oxygen-gtk"
+ elog "for example."
+ einfo
+}