summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-03-22 23:08:45 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-03-23 00:01:00 +0100
commit7f1d67d613f3aff04b6d7c7dae84ef8df44a7b80 (patch)
treeb52e8a560052fe6e05297c8c60c24f73a1d16761 /kde-plasma/kpipewire
parentkde-plasma/kde-gtk-config: drop 5.27.3 (diff)
downloadgentoo-7f1d67d613f3aff04b6d7c7dae84ef8df44a7b80.tar.gz
gentoo-7f1d67d613f3aff04b6d7c7dae84ef8df44a7b80.tar.bz2
gentoo-7f1d67d613f3aff04b6d7c7dae84ef8df44a7b80.zip
kde-plasma/kpipewire: Backport 5.27.4 fixes
Aleix Pol (8): recording: Extend the encoders API recording: Allocate frames when we render record: Allocate SwsContext only when necessary record: Refactor thread distribution record: Improve packet fetching record: Make sure we process all the frames before leaving record: Use a good amount of threads as recommended by QThread record: Only create the sws_context when necessary Jan Grulich (1): Use a different API call to make importing DmaBufs work on Nvidia Marco Martin (1): options to disable motion estimation and in-loop filtering KDE-bug: https://bugs.kde.org/show_bug.cgi?id=448839 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kpipewire')
-rw-r--r--kde-plasma/kpipewire/Manifest1
-rw-r--r--kde-plasma/kpipewire/kpipewire-5.27.3-r1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/kde-plasma/kpipewire/Manifest b/kde-plasma/kpipewire/Manifest
index d93ff7050d57..c3eaeb6a3d11 100644
--- a/kde-plasma/kpipewire/Manifest
+++ b/kde-plasma/kpipewire/Manifest
@@ -1,2 +1,3 @@
DIST kpipewire-5.26.5.tar.xz 52848 BLAKE2B c77263dd20d419fc590a1257b8934257f40f9c7751b4c1542db30fc4ba5814ae1076190d9fe08325398a9bc85f7321c6ed1059bf0b010debe20346110d211661 SHA512 59783fe9cb46ae467bc907a04bb0f499bdd23a39c607d7f0203dc550f2268a36e1914d55df90f167328f9b2644144642540e3d20ba27c6f1b66beff1c807d0d1
+DIST kpipewire-5.27.3-patchset-1.tar.xz 7904 BLAKE2B 6adf899abe28f515a98031c1d067eedc58f2aad1be15d1789c077df952c30e75e8c0be90a2d07b053872b8db5eabff4ab278a0273985c026440263f3963d5d7d SHA512 4cf12eecf3a173974dcd6bd1ea6a64a6bec3698eb8c72a0013a263d7a37d5928356d1a461c1f131bed8809eb2d54a81ccdfd694a383f873e203c47ba02e62b62
DIST kpipewire-5.27.3.tar.xz 58460 BLAKE2B 5245761517c9b651e69ea0699814bb6cad00de8333bf5a95894dcd41f3189aa95b80940f4fd6c27b6973eb7345d06f82536dfb6b9ba19334179196381d3094aa SHA512 4d4ffb45e698499b0092e7c0ede1a8c2dd8a3e27c57c0acd34982f266f111ceb900d2058c0c54a575bbd5cb3fd24a23fc358cbaf62e4a175289cf364ba49e9e3
diff --git a/kde-plasma/kpipewire/kpipewire-5.27.3-r1.ebuild b/kde-plasma/kpipewire/kpipewire-5.27.3-r1.ebuild
new file mode 100644
index 000000000000..9261a85c0d9f
--- /dev/null
+++ b/kde-plasma/kpipewire/kpipewire-5.27.3-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+KFMIN=5.102.0
+QTMIN=5.15.7
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Components relating to Flatpak pipewire use in Plasma"
+SRC_URI+=" https://dev.gentoo.org/~asturm/distfiles/${P}-patchset-1.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ dev-libs/wayland
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ media-libs/libepoxy
+ media-libs/libglvnd
+ media-video/ffmpeg:=
+ >=media-video/pipewire-0.3:=
+ x11-libs/libdrm
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/plasma-wayland-protocols
+"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ x11-themes/sound-theme-freedesktop
+"
+BDEPEND=">=dev-qt/qtwaylandscanner-${QTMIN}:5"
+
+PATCHES=( "${WORKDIR}/${P}-patchset-1" ) # KDE-bug 448839