summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-25 16:00:00 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-29 10:26:15 +0200
commit5da0293ca71c4608b453b99db6a9202db5e87143 (patch)
treedb667399d40199eeede6caae148812fc855b351c /kde-plasma/ksysguard
parentapp-portage/eix: Fix C++ standard to C++14 to fix code bugs (diff)
downloadgentoo-5da0293ca71c4608b453b99db6a9202db5e87143.tar.gz
gentoo-5da0293ca71c4608b453b99db6a9202db5e87143.tar.bz2
gentoo-5da0293ca71c4608b453b99db6a9202db5e87143.zip
kde-plasma: Add KDE Plasma 5.12.7
Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'kde-plasma/ksysguard')
-rw-r--r--kde-plasma/ksysguard/Manifest1
-rw-r--r--kde-plasma/ksysguard/ksysguard-5.12.7.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/kde-plasma/ksysguard/Manifest b/kde-plasma/ksysguard/Manifest
index 34fe93b5d428..2fad304bc889 100644
--- a/kde-plasma/ksysguard/Manifest
+++ b/kde-plasma/ksysguard/Manifest
@@ -1,3 +1,4 @@
DIST ksysguard-5.12.5.tar.xz 486676 BLAKE2B 4c706d719920beaf1ec831d23d918a254e01281e89232b1b36e9ca0f5a3134b3b688f7b37af3f41836808a3a3d8ac8052da65df80198ab8ad20fcfa288e868db SHA512 02f5b64a39e395869479ab93ef683136b7017dfb51e55dc03206641bd46052e656547244fc2b6cd86902d5a4f08a5a8fd7d1d5ba0fed73c765a2cfbc39f4bd32
DIST ksysguard-5.12.6.tar.xz 490700 BLAKE2B 983efe089236f929f0eaef8c43c17a57223c1710d153240b10a76cdacbda974b4c135b3002a89edc72be605fcf07a61e02de9c00aa7291d84777b71190a2e86b SHA512 ca0d21e6ed8fc8b042c6a0fbbfd0fa57811bf0e90da323df32c7905f8ce96155b67916d3038f8a993ab8e12383c1a3131d5d3bfb028cc374ea46129046f5ad81
+DIST ksysguard-5.12.7.tar.xz 496904 BLAKE2B da069b522a5f4de685f7b5421fc427026f7bff892e9aee30bad4713717f4864edf0a8314066fc97749fb5e712944c07e29d95ac26afb8f4a05a81104f7844e2f SHA512 745958c74914d9b21373919b0e54cf7d1dd0621769aa8a480bac924862c494c68c86fa36c019fb13d71d8d86c8d923161290ef9a967b98c1182df88da63bbb35
DIST ksysguard-5.13.5.tar.xz 497776 BLAKE2B 15daec09221993a9c5f39845a3cd168d01ee9a367020312507ac96615722fdf0e5244b3130dd5f09905db8a95b7ddf5df58cdada64a1e291c069f1b58912e684 SHA512 3df272468c6ea1a1211fd9f1e40bab5be8cdff8cb02556999cde8dde81042d6a0d8ad3958faf507323d7770f6dc2631d9ceba7ade796f8927719ce4a8659ca21
diff --git a/kde-plasma/ksysguard/ksysguard-5.12.7.ebuild b/kde-plasma/ksysguard/ksysguard-5.12.7.ebuild
new file mode 100644
index 000000000000..4b2349e1b061
--- /dev/null
+++ b/kde-plasma/ksysguard/ksysguard-5.12.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Network-enabled task manager and system monitor"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="lm_sensors"
+
+DEPEND="
+ $(add_plasma_dep libksysguard '-minimal(-)')
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ lm_sensors? ( sys-apps/lm_sensors )
+"
+RDEPEND="${DEPEND}
+ !kde-plasma/ksysguard:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package lm_sensors Sensors)
+ )
+
+ kde5_src_configure
+}