summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-04-16 21:10:53 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-04-16 21:50:25 +0200
commit06335c0bcae7bac1509f1051110dc3e794c0f669 (patch)
tree84dc3105c4bbeda39e6073be23ec963745d60726 /kde-plasma/kwallet-pam
parentkde-plasma/ksystemstats: add 6.0.4 (diff)
downloadgentoo-06335c0bcae7bac1509f1051110dc3e794c0f669.tar.gz
gentoo-06335c0bcae7bac1509f1051110dc3e794c0f669.tar.bz2
gentoo-06335c0bcae7bac1509f1051110dc3e794c0f669.zip
kde-plasma/kwallet-pam: add 6.0.4
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-6.0.4.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index 2292781946dc..44408e68117c 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-pam-5.27.11.tar.xz 22948 BLAKE2B 1c0cf86bb7e57696e44ac34a4392d1f81a6ade8fbaef6c61eefc79df39890aa1799ddbb39ec59fbde3ea4536c1113c1147b28bcdfc898049e847af99b107267b SHA512 b52177df434bf71214874a2410637240bb5a23f0fd06d41f3b62630d90e5262a231012c4f11119f96c151bb222e73652e5e8506ccc26c7cc451090f3bd156b6a
DIST kwallet-pam-6.0.3.tar.xz 23008 BLAKE2B 97253e71ac17573ac9522a59223ed9b8d4be065da1233f29e9376480cc1d8ae3e08823130836f1420f8cd494a6714da71d64f4e7ad843ff69146fc8604457282 SHA512 bdef907847de6a9aeef46e3e00488643f9f965b91cec547e6d14e948558aded1738fcf3f84da6de137375945fb67fb5913da5fbaebe0a08e2e313bbabb8e93ed
+DIST kwallet-pam-6.0.4.tar.xz 23016 BLAKE2B cd1abeb02c7d734db35848318613cfff54b98c7e06c8ec3ced237bcdf154d4808c5e5e7c04d70a7469f479566e9cc12626e038b40735b7d8004cd03797c4a406 SHA512 af186165fe2e2ada5e1dd8359b41980af36e18b5266048fd3dbeeb4e2815ec158a1d1079d0c25ea427dc4c43414bf985c8eea828eafe54d9c58bc4b3c59255c6
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-6.0.4.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-6.0.4.ebuild
new file mode 100644
index 000000000000..cb964d02d812
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-6.0.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=6.0
+PVCUT=$(ver_cut 1-3)
+inherit ecm plasma.kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=kde-frameworks/kwallet-${KFMIN}:6
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:6."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}