summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-25 23:25:31 +0100
committerSam James <sam@gentoo.org>2024-06-25 23:31:02 +0100
commite364ef65c96d845c7687d76c86a41fcd3262af83 (patch)
treee5cc5151ec3d7350343c24646437a0f95bfe6d4e /kde-plasma/plasma-firewall
parentkde-plasma/plasma-disks: 6.1.1 version bump (diff)
downloadgentoo-e364ef65c96d845c7687d76c86a41fcd3262af83.tar.gz
gentoo-e364ef65c96d845c7687d76c86a41fcd3262af83.tar.bz2
gentoo-e364ef65c96d845c7687d76c86a41fcd3262af83.zip
kde-plasma/plasma-firewall: 6.1.1 version bump
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-firewall')
-rw-r--r--kde-plasma/plasma-firewall/Manifest1
-rw-r--r--kde-plasma/plasma-firewall/plasma-firewall-6.1.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/kde-plasma/plasma-firewall/Manifest b/kde-plasma/plasma-firewall/Manifest
index 2410372c4eaf..5d538cb6a6ca 100644
--- a/kde-plasma/plasma-firewall/Manifest
+++ b/kde-plasma/plasma-firewall/Manifest
@@ -1,2 +1,3 @@
DIST plasma-firewall-5.27.11.tar.xz 362988 BLAKE2B 484e853f4a8c61823e2a235fe5d5e40b6861c04044ca5058b8e866d9a9d9cb072b8a64c2c1b8a950f1604acc85dd27c38314735db2b6e4f59e8fb9085eda0ea8 SHA512 9c6a41448ef83a1c464e1e10441ae811bc898afc451b821fbd46141df4ffe1ad395692c420ce02dd5618197a307fa2729dbe8f0f703c1a64b14068f6c018ba7b
DIST plasma-firewall-6.1.0.tar.xz 372628 BLAKE2B e2ce183f927213c21148e3c758ecccb175484dad79767509efbcf289551156cf895974ae11f73ebe4015e30da090489b29ff720852d0001ae1614e429a57da5e SHA512 00b8db564a4ae18a6524495238f8206a066afe944e846cea8b794ab603f4ef7401762ae06cf176a23ed10df8e772cf6033697b10894888c0462adb815fed163d
+DIST plasma-firewall-6.1.1.tar.xz 373880 BLAKE2B 790bbfe502aaeedfd94d054b5b2710b23abd16312737db73068f3da8f146cb90265048fdbe218e832998362244c09b12ea6f8e07881e123865cd0937a84de196 SHA512 bee4f12ea1ba9a194fc37a13c369c075ffddff9384428c4ac0b259888ef88e2004da7e34e2600350023b8400f81df028fe79fc3c13a4b333820f71b382ff730c
diff --git a/kde-plasma/plasma-firewall/plasma-firewall-6.1.1.ebuild b/kde-plasma/plasma-firewall/plasma-firewall-6.1.1.ebuild
new file mode 100644
index 000000000000..f39457cf3965
--- /dev/null
+++ b/kde-plasma/plasma-firewall/plasma-firewall-6.1.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+PYTHON_COMPAT=( python3_{10..12} )
+KFMIN=6.3.0
+QTMIN=6.7.1
+inherit ecm plasma.kde.org python-single-r1
+
+DESCRIPTION="Plasma frontend for Firewalld or UFW"
+HOMEPAGE="https://invent.kde.org/network/plasma-firewall"
+
+LICENSE="GPL-2+"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE="firewalld +ufw"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE} || ( firewalld ufw )"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,network,xml]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kauth-${KFMIN}:6
+ >=kde-frameworks/kcmutils-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ firewalld? ( net-firewall/firewalld )
+ ufw? ( net-firewall/ufw )
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:6"
+
+src_prepare() {
+ ecm_src_prepare
+ # this kind of cmake magic doesn't work for us at all.
+ sed -e "1 s:^.*$:\#\!/usr/bin/env ${EPYTHON}:" \
+ -i kcm/backends/ufw/helper/kcm_ufw_helper.py.cmake || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_FIREWALLD_BACKEND=$(usex firewalld)
+ -DBUILD_UFW_BACKEND=$(usex ufw)
+ )
+ ecm_src_configure
+}
+
+pkg_postinst () {
+ ecm_pkg_postinst
+
+ if ! has_version sys-apps/systemd; then
+ ewarn "${PN} is not functional without sys-apps/systemd at this point."
+ ewarn "See also: https://bugs.gentoo.org/778527"
+ fi
+}