summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-10-22 23:13:12 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-23 00:18:55 +0200
commit6934fb0cf9965bf8869fae836a694b6239492010 (patch)
tree944c71ec6ecefb760c3b7057ab75acd3738e6778 /kde-plasma
parentdev-util/cbindgen: new package (diff)
downloadgentoo-6934fb0cf9965bf8869fae836a694b6239492010.tar.gz
gentoo-6934fb0cf9965bf8869fae836a694b6239492010.tar.bz2
gentoo-6934fb0cf9965bf8869fae836a694b6239492010.zip
x11-misc/xembedsniproxy: pkgmove to kde-plasma/xembed-sni-proxy
Bug: https://bugs.gentoo.org/669314 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/xembed-sni-proxy/Manifest1
-rw-r--r--kde-plasma/xembed-sni-proxy/files/xembed-sni-proxy-5.10.3-Standalone-build.patch47
-rw-r--r--kde-plasma/xembed-sni-proxy/metadata.xml12
-rw-r--r--kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.12.0.ebuild37
4 files changed, 97 insertions, 0 deletions
diff --git a/kde-plasma/xembed-sni-proxy/Manifest b/kde-plasma/xembed-sni-proxy/Manifest
new file mode 100644
index 000000000000..7fab7d60fdeb
--- /dev/null
+++ b/kde-plasma/xembed-sni-proxy/Manifest
@@ -0,0 +1 @@
+DIST plasma-workspace-5.12.0.tar.xz 4571240 BLAKE2B 817d227cee4e1c4a47fd0c948534d24dec77eb71e9f09ec8a9b226264678d86682234431102133e02342cf61627f981d24289fa9b210da20ff475b2775edcb53 SHA512 9bcdca74cbcff539f4431b8f888143ff278ed79c5b24033c0f81124a4e2eb5538eec959d5ad9e52aa553f2803634ff189957358d83d78a3d76122699a8add6ce
diff --git a/kde-plasma/xembed-sni-proxy/files/xembed-sni-proxy-5.10.3-Standalone-build.patch b/kde-plasma/xembed-sni-proxy/files/xembed-sni-proxy-5.10.3-Standalone-build.patch
new file mode 100644
index 000000000000..8ccd2ad0bd59
--- /dev/null
+++ b/kde-plasma/xembed-sni-proxy/files/xembed-sni-proxy-5.10.3-Standalone-build.patch
@@ -0,0 +1,47 @@
+From c19bc38c85ca14df7034ef4c97b0681de1c1a6a2 Mon Sep 17 00:00:00 2001
+From: Mykyta Holubakha <hilobakho@gmail.com>
+Date: Sat, 15 Jul 2017 15:52:30 +0300
+Subject: [PATCH] Standalone xembedsniproxy build
+
+---
+ xembed-sni-proxy/CMakeLists.txt | 27 +++++++++++++++++++++++++++
+ 1 file changed, 27 insertions(+)
+
+diff --git a/xembed-sni-proxy/CMakeLists.txt b/xembed-sni-proxy/CMakeLists.txt
+index c2f67ac6..e74c7437 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,3 +1,30 @@
++cmake_minimum_required(VERSION 2.8.12 FATAL_ERROR)
++
++project(plasma-workspace)
++
++set(QT_MIN_VERSION "5.7.0")
++set(KF5_MIN_VERSION "5.34.0")
++
++find_package(Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED COMPONENTS
++ Core
++ DBus
++ X11Extras
++)
++
++
++find_package(ECM 1.8.0 REQUIRED NO_MODULE)
++set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
++
++include(KDEInstallDirs)
++include(KDECMakeSettings)
++include(KDECompilerSettings NO_POLICY_SCOPE)
++include(FeatureSummary)
++include(ECMOptionalAddSubdirectory)
++include(ECMQtDeclareLoggingCategory)
++
++find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS WindowSystem)
++find_package(X11)
++
+ add_definitions(-DQT_NO_CAST_TO_ASCII
+ -DQT_NO_CAST_FROM_ASCII
+ -DQT_NO_URL_CAST_FROM_STRING
+--
+2.13.1
+
diff --git a/kde-plasma/xembed-sni-proxy/metadata.xml b/kde-plasma/xembed-sni-proxy/metadata.xml
new file mode 100644
index 000000000000..3554bdb770b5
--- /dev/null
+++ b/kde-plasma/xembed-sni-proxy/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hilobakho@gmail.com</email>
+ <name>Mykyta Holubakha</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Gentoo Proxy Maintainers Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.12.0.ebuild b/kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.12.0.ebuild
new file mode 100644
index 000000000000..87e53f0a5252
--- /dev/null
+++ b/kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.12.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A program to use legacy Xembed tray icons with SNI-only trays"
+HOMEPAGE="https://cgit.kde.org/plasma-workspace.git/tree/xembed-sni-proxy/Readme.md"
+SRC_URI="mirror://kde/stable/plasma/${PV}/plasma-workspace-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtdbus:5
+ dev-qt/qtx11extras:5
+ kde-frameworks/kwindowsystem:5
+ x11-libs/libxcb
+ x11-libs/libXtst
+ x11-libs/xcb-util-image
+"
+DEPEND="
+ kde-frameworks/extra-cmake-modules:5
+ ${CDEPEND}
+"
+RDEPEND="
+ !kde-plasma/plasma-workspace:5
+ ${CDEPEND}
+"
+
+S="${WORKDIR}/plasma-workspace-${PV}/${PN}"
+
+PATCHES=( "${FILESDIR}/${PN}-5.10.3-Standalone-build.patch" )