summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-07-26 23:40:30 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-07-27 00:02:02 +0200
commite83c98869958f99da1b5bc1f838bc6f5fae9b6ea (patch)
tree039818f782a164924bc31a7aac462c8e1c1ba867 /mail-client
parentnet-misc/dhcpcd: stable 7.2.3 for ia64, bug #690682 (diff)
downloadgentoo-e83c98869958f99da1b5bc1f838bc6f5fae9b6ea.tar.gz
gentoo-e83c98869958f99da1b5bc1f838bc6f5fae9b6ea.tar.bz2
gentoo-e83c98869958f99da1b5bc1f838bc6f5fae9b6ea.zip
mail-client/claws-mail: Added "litehtml" USE flag to live ebuild
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/claws-mail/claws-mail-9999.ebuild17
-rw-r--r--mail-client/claws-mail/metadata.xml32
2 files changed, 23 insertions, 26 deletions
diff --git a/mail-client/claws-mail/claws-mail-9999.ebuild b/mail-client/claws-mail/claws-mail-9999.ebuild
index e0747aeb75cb..f460e8d37fc5 100644
--- a/mail-client/claws-mail/claws-mail-9999.ebuild
+++ b/mail-client/claws-mail/claws-mail-9999.ebuild
@@ -20,7 +20,7 @@ fi
SLOT="0"
LICENSE="GPL-3"
-IUSE="archive bogofilter calendar clamav dbus debug dillo doc gdata +gnutls gtk3 +imap ipv6 ldap +libcanberra +libindicate +libnotify networkmanager nls nntp +notification pda pdf perl +pgp python rss session sieve smime spamassassin spam-report spell startup-notification svg valgrind xface"
+IUSE="archive bogofilter calendar clamav dbus debug dillo doc gdata +gnutls gtk3 +imap ipv6 ldap +libcanberra +libindicate +libnotify litehtml networkmanager nls nntp +notification pda pdf perl +pgp python rss session sieve smime spamassassin spam-report spell startup-notification svg valgrind xface"
REQUIRED_USE="libcanberra? ( notification )
libindicate? ( notification )
libnotify? ( notification )
@@ -56,6 +56,12 @@ COMMONDEPEND="
!gtk3? ( >=x11-libs/gtk+-2.24:2 )
imap? ( >=net-libs/libetpan-0.57 )
ldap? ( >=net-nds/openldap-2.0.7 )
+ litehtml? (
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/gumbo-0.10
+ net-misc/curl
+ media-libs/fontconfig
+ )
nls? ( >=sys-devel/gettext-0.18 )
nntp? ( >=net-libs/libetpan-0.57 )
notification? (
@@ -80,10 +86,12 @@ COMMONDEPEND="
"
DEPEND="${COMMONDEPEND}
+ xface? ( >=media-libs/compface-1.4 )
+"
+BDEPEND="
app-arch/xz-utils
virtual/pkgconfig
- xface? ( >=media-libs/compface-1.4 )"
-
+"
RDEPEND="${COMMONDEPEND}
app-misc/mime-types
x11-misc/shared-mime-info
@@ -140,6 +148,7 @@ src_configure() {
$(use_enable gtk3)
$(use_enable ipv6)
$(use_enable ldap)
+ $(use_enable litehtml litehtml_viewer-plugin)
$(use_enable networkmanager)
$(use_enable nls)
$(use_enable notification notification-plugin)
@@ -199,7 +208,7 @@ src_install() {
doexe tb2claws-mail update-po uudec uuooffice
# kill useless files
- rm -f "${ED%/}"/usr/lib*/claws-mail/plugins/*.{a,la}
+ rm -f "${ED}"/usr/lib*/claws-mail/plugins/*.{a,la}
}
pkg_preinst() {
diff --git a/mail-client/claws-mail/metadata.xml b/mail-client/claws-mail/metadata.xml
index aa9acebdfde3..215b58ddd53d 100644
--- a/mail-client/claws-mail/metadata.xml
+++ b/mail-client/claws-mail/metadata.xml
@@ -7,32 +7,20 @@
</maintainer>
<use>
<flag name="archive">Enable archiving plugin</flag>
+ <flag name="bogofilter">Build <pkg>mail-filter/bogofilter</pkg> plugin</flag>
<flag name="dillo">Enable dillo html viewer plugin</flag>
- <flag name="gdata">Enable plugin for access to Google
- data providers</flag>
+ <flag name="gdata">Enable plugin for access to Google data providers</flag>
<flag name="gtk3">Build support for GTK+3</flag>
+ <flag name="libcanberra">Enable sound notification in connection with USE=notification</flag>
+ <flag name="libindicate">Enable notification through DBUS in connection with USE=notification</flag>
+ <flag name="libnotify">Enable notification on the desktop in connection with USE=notification</flag>
+ <flag name="litehtml">Enable <pkg>dev-libs/gumbo</pkg> html viewer plugin</flag>
+ <flag name="notification">Notification for new mail in different way, see also USE flags libcanberra, libindicate and libnotify</flag>
<flag name="pgp">Enable PGP support</flag>
- <flag name="spam-report">Enable plugin for spam
- reporting to various services</flag>
- <flag name="bogofilter">Build <pkg>mail-filter/bogofilter</pkg>
- plugin</flag>
- <flag name="libcanberra">Enable sound notification in connection
- with USE=notification</flag>
- <flag name="libindicate">Enable notification through
- DBUS in connection with USE=notification</flag>
- <flag name="libnotify">Enable notification on the
- desktop in connection with USE=notification</flag>
- <flag name="notification">Notification for new mail in
- different way, see also USE flags libcanberra,
- libindicate and libnotify</flag>
<flag name="sieve">Build plugin for sieve filter support</flag>
<flag name="smime">Build plugin for S/MIME support</flag>
- <flag name="spamassassin">Build <pkg>mail-filter/spamassassin</pkg>
- plugin</flag>
- <flag name="valgrind">Add support for memory debugging
- using valgrind</flag>
+ <flag name="spam-report">Enable plugin for spam reporting to various services</flag>
+ <flag name="spamassassin">Build <pkg>mail-filter/spamassassin</pkg> plugin</flag>
+ <flag name="valgrind">Add support for memory debugging using valgrind</flag>
</use>
- <upstream>
- <remote-id type="sourceforge">sylpheed-claws</remote-id>
- </upstream>
</pkgmetadata>