summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-09-06 20:26:38 +0200
committerPacho Ramos <pacho@gentoo.org>2024-09-06 20:26:38 +0200
commita0e6b5943e100320c773b0852787fe425301a3b1 (patch)
tree0f99fd25299b6ce40c79627a07400f6f2c14671c /media-fonts
parentprofiles/arch/mips: mask media-libs/libavif[rav1e] (diff)
downloadgentoo-a0e6b5943e100320c773b0852787fe425301a3b1.tar.gz
gentoo-a0e6b5943e100320c773b0852787fe425301a3b1.tar.bz2
gentoo-a0e6b5943e100320c773b0852787fe425301a3b1.zip
media-fonts/noto: add 20240830
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'media-fonts')
-rw-r--r--media-fonts/noto/Manifest1
-rw-r--r--media-fonts/noto/noto-20240830.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/media-fonts/noto/Manifest b/media-fonts/noto/Manifest
index 4906b0e698af..d19a7e3be75d 100644
--- a/media-fonts/noto/Manifest
+++ b/media-fonts/noto/Manifest
@@ -2,3 +2,4 @@ DIST noto-20240430.tar.gz 1067709428 BLAKE2B 068b49614efaf6136fb166d21cd01ed381a
DIST noto-20240531.tar.gz 1067977032 BLAKE2B 769468b6232eab061703df8d8dc026fa82d6005c0c53ff0a483557fd33e6c52ac3dc7e65f5444390d9130e0b0f04e5ecb71109462bc985e17cbd7d4112a9ab0d SHA512 2be323d3eaf5db9598950148d3d89824f97f2fef5aeea323862e3ef430de4ebf24b942d71319fbdee711778e78810b28cf76f3d6f815dd404db660d276f3f4eb
DIST noto-20240630.tar.gz 1089432282 BLAKE2B 07984ab5deb385855122bd1688b237ef2c59956e7516db16f4ed2b683b1c04ae73c06bc4e5ba766077fb479e774a38a6ab97a318299b0581032dedb9ad7c3cc0 SHA512 eb0a0416c2a12b1a37f867d0f13a55d1d169466786fd367de246c67008c5def9c49eb942e81aaf9810f5c071cca076fa9019b92b11e169a48fe0b15dc7ce43aa
DIST noto-20240731.tar.gz 1087189796 BLAKE2B 939cc60437521166c01c7255c23e33fa29d8eebd186191bde8bc79a3b9a27c25e9b393af92a55926b398f8540da2c676cda3720d844689d38b029397620e4c88 SHA512 0361b602f6e9545ffdcae85674f8d3bec1235cec506a271a5f857f80f339562972461dc70d89ebf0dce42bb13235e0b59c0b121292983843534cb489c69b4218
+DIST noto-20240830.tar.gz 1087158158 BLAKE2B e3b3410fa3c3fbd48e3224f7a22a46377ffa50d36df4027902bd86949579d33ebfb883939feba62ce8520a10d1c982c0c600e7363d5e3a752e76d75059eedf5b SHA512 cf3ac08d2c1fb134194ce6b1211d63ab5fc00adcfc92106afdd872ad9fb75cbf0437d88314a8cc3681fa93974f37c736685f529231ad5e8f8eca429876ee0032
diff --git a/media-fonts/noto/noto-20240830.ebuild b/media-fonts/noto/noto-20240830.ebuild
new file mode 100644
index 000000000000..73e020cb6c44
--- /dev/null
+++ b/media-fonts/noto/noto-20240830.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit font
+
+DESCRIPTION="Google's font family that aims to support all the world's languages"
+HOMEPAGE="https://fonts.google.com/noto https://github.com/notofonts/notofonts.github.io"
+
+COMMIT="eeb71fdda20300eb0891badeed5e64850e2cbc64"
+SRC_URI="https://github.com/notofonts/notofonts.github.io/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/notofonts.github.io-${COMMIT}"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+# Extra allows to optionally reduce disk usage even returning to tofu
+# issue as described in https://fonts.google.com/noto
+IUSE="cjk +extra"
+
+RDEPEND="cjk? ( media-fonts/noto-cjk )"
+
+RESTRICT="binchecks strip"
+
+FONT_SUFFIX="ttf"
+FONT_CONF=(
+ # From ArchLinux
+ "${FILESDIR}/66-noto-serif.conf"
+ "${FILESDIR}/66-noto-mono.conf"
+ "${FILESDIR}/66-noto-sans.conf"
+)
+
+src_install() {
+ mkdir install-hinted || die
+ mv fonts/*/hinted/ttf/*.tt[fc] install-hinted/. || die
+
+ FONT_S="${S}/install-hinted/" font_src_install
+
+ # Allow to drop some fonts optionally for people that want to save
+ # disk space. Following ArchLinux options.
+ use extra || rm -rf "${ED}"/usr/share/fonts/noto/Noto*{Condensed,SemiBold,Extra}*.tt[f,c]
+}