summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-07-03 21:26:16 -0600
committerTim Harder <radhermit@gentoo.org>2019-07-03 21:26:47 -0600
commitf30b8bc6e843fa2e4c029f9ffe71637464a70d2a (patch)
treedec3f1f21851e596cfb96b39a30c24f234a9f250 /media-gfx/cptutils
parentmedia-gfx/dcraw: remove old (diff)
downloadgentoo-f30b8bc6e843fa2e4c029f9ffe71637464a70d2a.tar.gz
gentoo-f30b8bc6e843fa2e4c029f9ffe71637464a70d2a.tar.bz2
gentoo-f30b8bc6e843fa2e4c029f9ffe71637464a70d2a.zip
media-gfx/cptutils: version bump to 1.71
Closes: https://bugs.gentoo.org/631384 Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'media-gfx/cptutils')
-rw-r--r--media-gfx/cptutils/Manifest1
-rw-r--r--media-gfx/cptutils/cptutils-1.71.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/media-gfx/cptutils/Manifest b/media-gfx/cptutils/Manifest
index 6999a7e1bf87..4f0e644540bc 100644
--- a/media-gfx/cptutils/Manifest
+++ b/media-gfx/cptutils/Manifest
@@ -1 +1,2 @@
DIST cptutils-1.68.tar.gz 623381 BLAKE2B 403d8ab3878c14b278d0e006fdd3f3f7223ae106c4b95fa10cebc9ffceb5a3164771a452996038d06e714b07dbeaafde33954f1428d20817fd02a991dcec3121 SHA512 e618ea4463a026c56c95e8e4a9bfb0f5d47825568e7f64885bcf3872d4411af4e1ff480f192c61d9d8c946a46100d148c849fd3768f3acd54b070aacdd8dc1cc
+DIST cptutils-1.71.tar.gz 626215 BLAKE2B 88d0166616d00df13011e8cea88d0cbe183e512f94ca2540ef135e8f77535087694f9aafe43b0e10307e513ba3c305881314bbd0890a3f9fd3f5b22da152a1a0 SHA512 65214a50f3741cc89ac4d3d92973f307c3030926e496a5cecf26dd7457d683296daf44ed0df7b1ddf96c657cebe7087193e410c109f6a6dd2fb6ae987158e778
diff --git a/media-gfx/cptutils/cptutils-1.71.ebuild b/media-gfx/cptutils/cptutils-1.71.ebuild
new file mode 100644
index 000000000000..9ad0b07f6f4b
--- /dev/null
+++ b/media-gfx/cptutils/cptutils-1.71.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="A number of utilities for the manipulation of color gradient files"
+HOMEPAGE="http://soliton.vm.bytemark.co.uk/pub/jjg/en/code/cptutils/"
+SRC_URI="http://soliton.vm.bytemark.co.uk/pub/jjg/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+CDEPEND="dev-libs/libxml2:2
+ media-libs/libpng:0="
+RDEPEND="${CDEPEND}
+ ${PYTHON_DEPS}"
+DEPEND="${CDEPEND}
+ test? (
+ app-text/xml2
+ app-text/xmlstarlet
+ >=dev-util/cunit-2.1_p3
+ )"
+
+src_prepare() {
+ default
+ python_fix_shebang src/gradient-convert/gradient-convert.py
+}
+
+src_configure() {
+ econf $(use_enable test tests)
+}
+
+src_test() {
+ emake unit
+}