summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2018-09-24 21:59:36 +0200
committerSebastian Pipping <sping@gentoo.org>2018-09-24 22:38:37 +0200
commitfea4860e2c82475880cf566e304f41df80c99f69 (patch)
treef5bf86dc90e3bb12af798ae3db415ae20e3c5704 /media-gfx/gimp/gimp-9999.ebuild
parentdev-db/mysql: Fix initial password setting in 5.6 (diff)
downloadgentoo-fea4860e2c82475880cf566e304f41df80c99f69.tar.gz
gentoo-fea4860e2c82475880cf566e304f41df80c99f69.tar.bz2
gentoo-fea4860e2c82475880cf566e304f41df80c99f69.zip
media-gfx/gimp: Avoid colliding with pre-2.10.6 plug-ins
Bug: https://bugs.gentoo.org/664938 Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'media-gfx/gimp/gimp-9999.ebuild')
-rw-r--r--media-gfx/gimp/gimp-9999.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/media-gfx/gimp/gimp-9999.ebuild b/media-gfx/gimp/gimp-9999.ebuild
index 82186f49ec6f..e44b1d4fca7c 100644
--- a/media-gfx/gimp/gimp-9999.ebuild
+++ b/media-gfx/gimp/gimp-9999.ebuild
@@ -165,6 +165,24 @@ _clean_up_locales() {
done
}
+# for https://bugs.gentoo.org/664938
+_rename_plugins() {
+ einfo 'Renaming plug-ins to not collide with pre-2.10.6 file layout (bug #664938)...'
+ local prepend=gimp-org-
+ (
+ cd "${ED%/}"/usr/$(get_libdir)/gimp/2.0/plug-ins || exit 1
+ for plugin_slash in $(ls -d1 */); do
+ plugin=${plugin_slash%/}
+ if [[ -f ${plugin}/${plugin} ]]; then
+ # NOTE: Folder and file name need to match for Gimp to load that plug-in
+ # so "file-svg/file-svg" becomes "${prepend}file-svg/${prepend}file-svg"
+ mv ${plugin}/{,${prepend}}${plugin} || exit 1
+ mv {,${prepend}}${plugin} || exit 1
+ fi
+ done
+ )
+}
+
src_test() {
virtx emake check
}
@@ -185,6 +203,7 @@ src_install() {
# Prevent dead symlink gimp-console.1 from downstream man page compression (bug #433527)
mv "${ED%/}"/usr/share/man/man1/gimp-console{-*,}.1 || die
+ _rename_plugins || die
_clean_up_locales
}