summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-09-22 15:31:24 +0000
committerSam James <sam@gentoo.org>2023-10-01 08:32:32 +0100
commitaa390cb06079d66e51dc8fccb9423ff6dd09fe4e (patch)
tree5e544724b7c262e66bb08756c2a65197f97d539b /media-gfx/hp2xx
parentdev-libs/libgpg-error: Use different autogen.sh fix for cross-prefix (diff)
downloadgentoo-aa390cb06079d66e51dc8fccb9423ff6dd09fe4e.tar.gz
gentoo-aa390cb06079d66e51dc8fccb9423ff6dd09fe4e.tar.bz2
gentoo-aa390cb06079d66e51dc8fccb9423ff6dd09fe4e.zip
media-gfx/hp2xx: Fix call to undeclared library function strcmp
Closes: https://bugs.gentoo.org/896218 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32996 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/hp2xx')
-rw-r--r--media-gfx/hp2xx/files/hp2xx-3.4.4-clang16-build.patch13
-rw-r--r--media-gfx/hp2xx/hp2xx-3.4.4-r4.ebuild84
2 files changed, 97 insertions, 0 deletions
diff --git a/media-gfx/hp2xx/files/hp2xx-3.4.4-clang16-build.patch b/media-gfx/hp2xx/files/hp2xx-3.4.4-clang16-build.patch
new file mode 100644
index 000000000000..20c8a143a6e3
--- /dev/null
+++ b/media-gfx/hp2xx/files/hp2xx-3.4.4-clang16-build.patch
@@ -0,0 +1,13 @@
+Bug: https://bugs.gentoo.org/896218
+--- a/sources/getopt.c
++++ b/sources/getopt.c
+@@ -22,6 +22,9 @@
+ along with this program; if not, write to the Free Software
+ Foundation, 675 Mass Ave, Cambridge, MA 02139, USA.
+ */
++
++#include <string.h>
++
+
+ /**
+ ** Additions / fixes for hp2xx
diff --git a/media-gfx/hp2xx/hp2xx-3.4.4-r4.ebuild b/media-gfx/hp2xx/hp2xx-3.4.4-r4.ebuild
new file mode 100644
index 000000000000..c71fb1376d07
--- /dev/null
+++ b/media-gfx/hp2xx/hp2xx-3.4.4-r4.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Convert Hewlett-Packard's HP-GL plotter language to other graphics formats"
+HOMEPAGE="https://www.gnu.org/software/hp2xx/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="jpeg png tiff X"
+
+RDEPEND="
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ png? (
+ media-libs/libpng:=
+ sys-libs/zlib
+ )
+ tiff? ( media-libs/tiff:= )
+ X? ( x11-libs/libX11 )"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-apps/texinfo"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-r1.patch
+ "${FILESDIR}"/${P}-docbuild.patch
+ "${FILESDIR}"/${P}-clang16-build.patch
+)
+
+src_prepare() {
+ default
+ cp -v makes/generic.mak sources/Makefile || die
+}
+
+src_configure() {
+ export PREVIEWER="no_prev"
+ export EX_SRC=
+ export EX_OBJ=
+ export EX_DEFS=-DUNIX
+ export ALL_LIBS=-lm
+
+ use jpeg && \
+ EX_SRC+=" to_jpg.c" \
+ EX_OBJ+=" to_jpg.o" \
+ EX_DEFS+=" -DJPG" \
+ ALL_LIBS+=" -ljpeg"
+ use png && \
+ EX_SRC+=" png.c to_png.c" \
+ EX_OBJ+=" png.o to_png.o" \
+ EX_DEFS+=" -DPNG" \
+ ALL_LIBS+=" -lpng"
+ use tiff && \
+ EX_SRC+=" to_tif.c" \
+ EX_OBJ+=" to_tif.o" \
+ EX_DEFS+=" -DTIF" \
+ ALL_LIBS+=" -ltiff"
+ use X && \
+ PREVIEWER="to_x11" \
+ EX_DEFS="-DHAS_UNIX_X11" \
+ ALL_LIBS+=" -lX11"
+
+ tc-export CC
+}
+
+src_compile() {
+ emake -C sources all
+}
+
+src_install() {
+ dodir \
+ /usr/bin \
+ /usr/share/info \
+ /usr/share/man/man1
+
+ emake \
+ prefix="${ED}"/usr \
+ mandir="${ED}"/usr/share/man \
+ infodir="${ED}"/usr/share/info \
+ install
+}