summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-08-29 18:26:41 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-08-29 18:47:48 +0200
commitbac6717f669476b6de842bb51a3cfa65c4e944c0 (patch)
tree1b2cf16743d22c79ec1e717a9089c0b0cc2bcbfe /media-gfx/krita
parentmedia-gfx/krita: Fix build with >=libraw-0.19 (diff)
downloadgentoo-bac6717f669476b6de842bb51a3cfa65c4e944c0.tar.gz
gentoo-bac6717f669476b6de842bb51a3cfa65c4e944c0.tar.bz2
gentoo-bac6717f669476b6de842bb51a3cfa65c4e944c0.zip
media-gfx/krita: Use patch, not KDE_TEST=forceoptional-recursive
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'media-gfx/krita')
-rw-r--r--media-gfx/krita/files/krita-4.0.3-tests-optional.patch324
-rw-r--r--media-gfx/krita/krita-4.0.3.ebuild7
2 files changed, 329 insertions, 2 deletions
diff --git a/media-gfx/krita/files/krita-4.0.3-tests-optional.patch b/media-gfx/krita/files/krita-4.0.3-tests-optional.patch
new file mode 100644
index 000000000000..c9e3ddc2aea3
--- /dev/null
+++ b/media-gfx/krita/files/krita-4.0.3-tests-optional.patch
@@ -0,0 +1,324 @@
+Autogenerated by KDE_TEST=forceoptional-recursive and edited.
+
+--- a/plugins/paintops/libpaintop/CMakeLists.txt 2018-08-29 18:17:38.843385842 +0200
++++ b/plugins/paintops/libpaintop/CMakeLists.txt 2018-08-29 18:17:38.846385865 +0200
+@@ -104,4 +104,6 @@
+ install(TARGETS kritalibpaintop ${INSTALL_TARGETS_DEFAULT_ARGS})
+
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+--- a/plugins/paintops/defaultpaintops/CMakeLists.txt 2018-08-29 18:17:38.851385903 +0200
++++ b/plugins/paintops/defaultpaintops/CMakeLists.txt 2018-08-29 18:17:38.854385926 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(brush/tests)
++endif()
+
+ include_directories(brush
+ duplicate
+--- a/plugins/impex/libkra/CMakeLists.txt 2018-08-29 18:17:38.858385956 +0200
++++ b/plugins/impex/libkra/CMakeLists.txt 2018-08-29 18:17:38.861385978 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(kritalibkra_LIB_SRCS
+ kis_colorize_dom_utils.cpp
+--- a/plugins/impex/exr/CMakeLists.txt 2018-08-29 18:17:38.866386016 +0200
++++ b/plugins/impex/exr/CMakeLists.txt 2018-08-29 18:17:38.869386039 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ include_directories(SYSTEM ${OPENEXR_INCLUDE_DIR} )
+
+--- a/plugins/impex/svg/CMakeLists.txt 2018-08-29 18:17:38.874386077 +0200
++++ b/plugins/impex/svg/CMakeLists.txt 2018-08-29 18:17:38.878386107 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(kritasvgimport_SOURCES
+ kis_svg_import.cc
+--- a/plugins/impex/jpeg/CMakeLists.txt 2018-08-29 18:17:38.883386145 +0200
++++ b/plugins/impex/jpeg/CMakeLists.txt 2018-08-29 18:17:38.887386175 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(ICCJPEG_SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/3rdparty/lcms")
+
+--- a/plugins/impex/heightmap/CMakeLists.txt 2018-08-29 18:17:38.892386213 +0200
++++ b/plugins/impex/heightmap/CMakeLists.txt 2018-08-29 18:17:38.896386243 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ include_directories( ${CMAKE_CURRENT_SOURCE_DIR} )
+
+--- a/plugins/impex/psd/CMakeLists.txt 2018-08-29 18:17:38.901386281 +0200
++++ b/plugins/impex/psd/CMakeLists.txt 2018-08-29 18:17:38.904386304 +0200
+@@ -1,5 +1,7 @@
+ if (NOT MSVC AND NOT APPLE)
+- add_subdirectory(tests)
++ if(BUILD_TESTING)
++ add_subdirectory(tests)
++ endif()
+ endif()
+
+ configure_file(config_psd.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config_psd.h)
+--- a/plugins/impex/ppm/CMakeLists.txt 2018-08-29 18:17:38.909386342 +0200
++++ b/plugins/impex/ppm/CMakeLists.txt 2018-08-29 18:17:38.913386372 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ include_directories( ${CMAKE_CURRENT_SOURCE_DIR} )
+
+--- a/plugins/impex/png/CMakeLists.txt 2018-08-29 18:17:38.918386410 +0200
++++ b/plugins/impex/png/CMakeLists.txt 2018-08-29 18:17:38.922386440 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(kritapngimport_SOURCES
+ kis_png_import.cc
+--- a/plugins/impex/csv/CMakeLists.txt 2018-08-29 18:17:38.927386478 +0200
++++ b/plugins/impex/csv/CMakeLists.txt 2018-08-29 18:17:38.931386508 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ # import
+
+--- a/plugins/impex/xcf/CMakeLists.txt 2018-08-29 18:17:38.936386546 +0200
++++ b/plugins/impex/xcf/CMakeLists.txt 2018-08-29 18:17:38.940386576 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(XCFTOOLS_SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/3rdparty/xcftools")
+
+--- a/plugins/impex/tiff/CMakeLists.txt 2018-08-29 18:17:38.944386606 +0200
++++ b/plugins/impex/tiff/CMakeLists.txt 2018-08-29 18:17:38.947386630 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(libkritatiffconverter_LIB_SRCS
+ kis_tiff_converter.cc
+--- a/plugins/extensions/qmic/CMakeLists.txt 2018-08-29 18:17:38.952386667 +0200
++++ b/plugins/extensions/qmic/CMakeLists.txt 2018-08-29 18:17:38.955386690 +0200
+@@ -20,4 +20,6 @@
+ target_link_libraries(kritaqmic kritaui)
+ install(TARGETS kritaqmic DESTINATION ${KRITA_PLUGIN_INSTALL_DIR})
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+--- a/plugins/filters/CMakeLists.txt 2018-08-29 18:17:38.959386720 +0200
++++ b/plugins/filters/CMakeLists.txt 2018-08-29 18:17:38.963386750 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+ add_subdirectory( blur )
+ add_subdirectory( colors )
+ add_subdirectory( colorsfilters )
+--- a/plugins/filters/unsharp/CMakeLists.txt 2018-08-29 18:17:38.968386788 +0200
++++ b/plugins/filters/unsharp/CMakeLists.txt 2018-08-29 18:17:38.971386811 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ set(kritaunsharpfilter_SOURCES
+ unsharp.cpp
+--- a/plugins/tools/basictools/CMakeLists.txt 2018-08-29 18:17:38.976386849 +0200
++++ b/plugins/tools/basictools/CMakeLists.txt 2018-08-29 18:17:38.980386879 +0200
+@@ -1,5 +1,7 @@
+ if (NOT APPLE)
+- add_subdirectory(tests)
++ if(BUILD_TESTING)
++ add_subdirectory(tests)
++ endif()
+ endif ()
+
+ set(kritadefaulttools_SOURCES
+--- a/plugins/tools/tool_transform2/CMakeLists.txt 2018-08-29 18:17:38.985386917 +0200
++++ b/plugins/tools/tool_transform2/CMakeLists.txt 2018-08-29 18:17:38.989386947 +0200
+@@ -1,5 +1,7 @@
+ if (NOT WIN32 AND NOT APPLE)
+- add_subdirectory(tests)
++ if(BUILD_TESTING)
++ add_subdirectory(tests)
++ endif()
+ endif()
+
+ set(kritatooltransform_SOURCES
+--- a/plugins/color/lcms2engine/CMakeLists.txt 2018-08-29 18:17:38.994386985 +0200
++++ b/plugins/color/lcms2engine/CMakeLists.txt 2018-08-29 18:17:38.998387015 +0200
+@@ -1,6 +1,8 @@
+ project( lcmsengine )
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ include_directories(SYSTEM
+ ${LCMS2_INCLUDE_DIR}
+--- a/plugins/dockers/defaultdockers/CMakeLists.txt 2018-08-29 18:17:39.003387053 +0200
++++ b/plugins/dockers/defaultdockers/CMakeLists.txt 2018-08-29 18:17:39.007387084 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ set(kritadefaultdockers_SOURCES
+ kis_layer_box.cpp
+--- a/plugins/dockers/animation/CMakeLists.txt 2018-08-29 18:17:39.012387121 +0200
++++ b/plugins/dockers/animation/CMakeLists.txt 2018-08-29 18:17:39.016387151 +0200
+@@ -1,5 +1,7 @@
+ if (NOT WIN32 AND NOT APPLE)
+- add_subdirectory(tests)
++ if(BUILD_TESTING)
++ add_subdirectory(tests)
++ endif()
+ endif()
+
+ set(KRITA_ANIMATIONDOCKER_SOURCES
+--- a/plugins/dockers/lut/CMakeLists.txt 2018-08-29 18:17:39.021387189 +0200
++++ b/plugins/dockers/lut/CMakeLists.txt 2018-08-29 18:17:39.025387220 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ include_directories(SYSTEM
+ ${OCIO_INCLUDE_DIR}
+--- a/libs/store/CMakeLists.txt 2018-08-29 18:17:39.030387258 +0200
++++ b/libs/store/CMakeLists.txt 2018-08-29 18:17:39.033387280 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(kritastore_LIB_SRCS
+ KoDirectoryStore.cpp
+--- a/libs/flake/CMakeLists.txt 2018-08-29 18:17:39.038387318 +0200
++++ b/libs/flake/CMakeLists.txt 2018-08-29 18:17:39.042387349 +0200
+@@ -9,7 +9,9 @@
+ )
+
+ add_subdirectory(styles)
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(kritaflake_SRCS
+ KoGradientHelper.cpp
+--- a/libs/widgetutils/CMakeLists.txt 2018-08-29 18:17:39.046387379 +0200
++++ b/libs/widgetutils/CMakeLists.txt 2018-08-29 18:17:39.049387401 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ configure_file(xmlgui/config-xmlgui.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-xmlgui.h )
+
+--- a/libs/odf/CMakeLists.txt 2018-08-29 18:17:39.054387439 +0200
++++ b/libs/odf/CMakeLists.txt 2018-08-29 18:17:39.058387469 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ set(kritaodf_LIB_SRCS
+ KoOdf.cpp
+--- a/libs/pigment/CMakeLists.txt 2018-08-29 18:17:39.062387500 +0200
++++ b/libs/pigment/CMakeLists.txt 2018-08-29 18:17:39.067387538 +0200
+@@ -31,7 +31,9 @@
+ message("${__per_arch_factory_objs}")
+ endif()
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+ add_subdirectory(benchmarks)
+
+ set(kritapigment_SRCS
+--- a/libs/widgets/CMakeLists.txt 2018-08-29 18:17:39.073387583 +0200
++++ b/libs/widgets/CMakeLists.txt 2018-08-29 18:17:39.078387621 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ include_directories(${CMAKE_CURRENT_BINARY_DIR})
+
+--- a/libs/ui/CMakeLists.txt 2018-08-29 18:17:39.084387666 +0200
++++ b/libs/ui/CMakeLists.txt 2018-08-29 18:17:39.088387697 +0200
+@@ -8,7 +8,9 @@
+ ${OCIO_INCLUDE_DIR}
+ )
+
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ if (APPLE)
+ find_library(FOUNDATION_LIBRARY Foundation)
+--- a/libs/image/CMakeLists.txt 2018-08-29 18:17:39.092387727 +0200
++++ b/libs/image/CMakeLists.txt 2018-08-29 18:17:39.096387757 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ add_subdirectory( tiles3 )
+
+--- a/libs/image/tiles3/CMakeLists.txt 2018-08-29 18:17:39.101387795 +0200
++++ b/libs/image/tiles3/CMakeLists.txt 2018-08-29 18:17:39.105387825 +0200
+@@ -1 +1,3 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+--- a/libs/global/CMakeLists.txt 2018-08-29 18:17:39.110387863 +0200
++++ b/libs/global/CMakeLists.txt 2018-08-29 18:17:39.113387886 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ include(CheckFunctionExists)
+ check_function_exists(backtrace HAVE_BACKTRACE)
+--- a/libs/brush/CMakeLists.txt 2018-08-29 18:17:39.117387916 +0200
++++ b/libs/brush/CMakeLists.txt 2018-08-29 18:17:39.121387946 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ include_directories(SYSTEM
+ ${EIGEN3_INCLUDE_DIR}
+--- a/libs/libkis/CMakeLists.txt 2018-08-29 18:17:39.126387984 +0200
++++ b/libs/libkis/CMakeLists.txt 2018-08-29 18:17:39.131388022 +0200
+@@ -46,4 +46,6 @@
+ install(TARGETS kritalibkis ${INSTALL_TARGETS_DEFAULT_ARGS})
+
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
diff --git a/media-gfx/krita/krita-4.0.3.ebuild b/media-gfx/krita/krita-4.0.3.ebuild
index fd16ae054383..72fdccfb6625 100644
--- a/media-gfx/krita/krita-4.0.3.ebuild
+++ b/media-gfx/krita/krita-4.0.3.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-KDE_TEST="forceoptional-recursive"
+KDE_TEST="forceoptional"
VIRTUALX_REQUIRED="test"
PYTHON_COMPAT=( python3_{4,5,6} )
inherit kde5 python-single-r1
@@ -86,7 +86,10 @@ RDEPEND="${COMMON_DEPEND}
# bug 630508
RESTRICT+=" test"
-PATCHES=( "${FILESDIR}/${P}-libraw-0.19.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-tests-optional.patch"
+ "${FILESDIR}/${P}-libraw-0.19.patch"
+)
pkg_setup() {
use python && python-single-r1_pkg_setup