summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Gerloff <chrgerloff@gmx.net>2019-10-12 21:07:44 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-12 23:13:15 +0200
commit4eb2a5e27aaa3a68864b9a2eb83c256ca703761d (patch)
tree50689fa3c316a7aef5d3d3258d08f06611ada0f0 /media-gfx/kuickshow/kuickshow-0.10.1.ebuild
parentkde-apps: Add KDE Applications 19.08.2 (diff)
downloadgentoo-4eb2a5e27aaa3a68864b9a2eb83c256ca703761d.tar.gz
gentoo-4eb2a5e27aaa3a68864b9a2eb83c256ca703761d.tar.bz2
gentoo-4eb2a5e27aaa3a68864b9a2eb83c256ca703761d.zip
media-gfx/kuickshow: bump version to 0.10.1
Signed-off-by: Christian Gerloff <chrgerloff@gmx.net> Bug: https://bugs.gentoo.org/696524 Package-Manager: Portage-2.3.69, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/13266 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/kuickshow/kuickshow-0.10.1.ebuild')
-rw-r--r--media-gfx/kuickshow/kuickshow-0.10.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-gfx/kuickshow/kuickshow-0.10.1.ebuild b/media-gfx/kuickshow/kuickshow-0.10.1.ebuild
new file mode 100644
index 000000000000..b75ef6343d8e
--- /dev/null
+++ b/media-gfx/kuickshow/kuickshow-0.10.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Image viewer based on KDE Frameworks"
+HOMEPAGE="https://userbase.kde.org/KuickShow"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ media-libs/imlib
+ x11-libs/libX11
+"
+RDEPEND="${DEPEND}
+ !media-gfx/kuickshow:4
+"