summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2017-09-21 10:29:30 +0100
committerDavid Seifert <soap@gentoo.org>2017-09-23 10:37:23 +0200
commitd63b3a02afa72407023a48914255dc8fbdf1bebf (patch)
tree8044a4f6fcaf3cd952b703e1dc7db3cb0e79b09c /media-gfx/openvdb/openvdb-4.0.2.ebuild
parentmedia-libs/ptex: revision bump to 2.1.28-r1 (diff)
downloadgentoo-d63b3a02afa72407023a48914255dc8fbdf1bebf.tar.gz
gentoo-d63b3a02afa72407023a48914255dc8fbdf1bebf.tar.bz2
gentoo-d63b3a02afa72407023a48914255dc8fbdf1bebf.zip
media-gfx/openvdb: version bump to 4.0.2
* Changed hardcoded paths to GNUInstallDirs * Patch to fixnumeric removal in Boost 1.65 * Use PkgConfig to find OpenEXR and IlmBase Bug: https://bugs.gentoo.org/612942 Closes: https://bugs.gentoo.org/611842 Closes: https://bugs.gentoo.org/630740 Closes: https://github.com/gentoo/gentoo/pull/5754
Diffstat (limited to 'media-gfx/openvdb/openvdb-4.0.2.ebuild')
-rw-r--r--media-gfx/openvdb/openvdb-4.0.2.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/media-gfx/openvdb/openvdb-4.0.2.ebuild b/media-gfx/openvdb/openvdb-4.0.2.ebuild
new file mode 100644
index 000000000000..aeac72948ca4
--- /dev/null
+++ b/media-gfx/openvdb/openvdb-4.0.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit cmake-utils flag-o-matic python-single-r1 versionator
+
+DESCRIPTION="Libs for the efficient manipulation of volumetric data"
+HOMEPAGE="http://www.openvdb.org"
+SRC_URI="https://github.com/dreamworksanimation/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/dracwyrm/gentoo-patches/raw/master/${PN}/${P}-patchset-01.tar.xz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+abi3-compat doc python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="sys-libs/zlib:=
+ >=dev-libs/boost-1.62:=[python?,${PYTHON_USEDEP}]
+ media-libs/openexr:=
+ media-libs/glfw:=
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXinerama
+ x11-libs/libXcursor
+ dev-libs/jemalloc
+ >=dev-libs/c-blosc-1.5.0
+ dev-libs/log4cplus
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-cpp/tbb
+ doc? ( app-doc/doxygen[latex] )"
+
+PATCHES=(
+ "${WORKDIR}/0001-Change-hardcoded-paths-to-GNUInstallDirs-variables.patch"
+ "${WORKDIR}/0002-Use-PkgConfig-to-find-IlmBase-and-OpenEXR.patch"
+ "${WORKDIR}/0003-Boost-1.65-NumPy-support.patch"
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local myprefix="${EPREFIX}/usr/"
+
+ # To stay in sync with Boost
+ append-cxxflags -std=c++14
+
+ local mycmakeargs=(
+ -DOPENVDB_BUILD_UNITTESTS=OFF
+ -DOPENVDB_BUILD_DOCS=$(usex doc)
+ -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
+ -DOPENVDB_BUILD_PYTHON_MODULE=$(usex python)
+ -DOPENVDB_ENABLE_3_ABI_COMPATIBLE=$(usex abi3-compat)
+ -DOPENVDB_ENABLE_RPATH=OFF
+ -DUSE_GLFW3=ON
+ -DBLOSC_LOCATION="${myprefix}"
+ -DGLEW_LOCATION="${myprefix}"
+ -DGLFW3_LOCATION="${myprefix}"
+ -DTBB_LOCATION="${myprefix}"
+ )
+
+ use python && mycmakeargs+=( -DPYOENVDB_INSTALL_DIRECTORY=${python_get_sitedir} )
+
+ cmake-utils_src_configure
+}