summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-11-19 20:43:39 -0500
committerTim Harder <radhermit@gentoo.org>2017-11-20 02:14:40 -0500
commita51a640d25343cb002abbf019aedb25244069c63 (patch)
tree165fb6e68899a691bb5d5996c10ea3521a5df6bc /media-gfx/pqiv
parentdev-ruby/rack-test: add 0.7.1 (diff)
downloadgentoo-a51a640d25343cb002abbf019aedb25244069c63.tar.gz
gentoo-a51a640d25343cb002abbf019aedb25244069c63.tar.bz2
gentoo-a51a640d25343cb002abbf019aedb25244069c63.zip
media-gfx/pqiv: version bump to 2.10.1
Diffstat (limited to 'media-gfx/pqiv')
-rw-r--r--media-gfx/pqiv/Manifest1
-rw-r--r--media-gfx/pqiv/pqiv-2.10.1.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/media-gfx/pqiv/Manifest b/media-gfx/pqiv/Manifest
index 204a6edfdbb1..76b304225777 100644
--- a/media-gfx/pqiv/Manifest
+++ b/media-gfx/pqiv/Manifest
@@ -1 +1,2 @@
+DIST pqiv-2.10.1.tar.gz 138129 SHA256 8f24ff072c17201703f68f139d31d82e239001b9612be4ad09c31e495372468d SHA512 9850f6693e7fd2942d105736a7d6a274388875770e194ac6bd8a5a8291db8fec1ee3a0262f911f2b8e5d115aa11d520c44d80cc8218e2c87d6935dea4dfcb97e WHIRLPOOL 904e53c204ed301fe250150a6d32f542d61a1ad0719dc128527e91a072004240510ee301e2385889c83f96e642d407a28b74465e510b0bbea0faa3171822f972
DIST pqiv-2.9.tar.gz 133823 SHA256 e57298ae7123bd6b01b751f6ef2d7a7853e731a3271b50095683442a406da99c SHA512 0a509d5d4b41682f86f4b813d63f3f7f8f3977ede0b8b1649a2adc188ed83923147b8bb741ba7f85b4c1dd7a9612fca3fec44169364042be4db44ef53d813ab7 WHIRLPOOL e40e4aab7b4df92cc7bed911531be4e84062196ca1fdae867b05da38f28c448a34475a31865275f0d38f3efedf1f07af42f305fcb6621a16a73f7050cb327652
diff --git a/media-gfx/pqiv/pqiv-2.10.1.ebuild b/media-gfx/pqiv/pqiv-2.10.1.ebuild
new file mode 100644
index 000000000000..68f387141219
--- /dev/null
+++ b/media-gfx/pqiv/pqiv-2.10.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit linux-info toolchain-funcs xdg-utils
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/phillipberndt/pqiv.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/phillipberndt/pqiv/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="powerful GTK 3 based command-line image viewer with a minimal UI"
+HOMEPAGE="https://github.com/phillipberndt/pqiv http://www.pberndt.com/Programme/Linux/pqiv/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="archive ffmpeg imagemagick kernel_linux libav pdf postscript webp"
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/cairo-1.6
+ x11-libs/gtk+:3
+ archive? ( app-arch/libarchive:0= )
+ ffmpeg? (
+ !libav? ( media-video/ffmpeg:0= )
+ libav? ( media-video/libav:0= )
+ )
+ imagemagick? ( media-gfx/imagemagick:0= )
+ pdf? ( app-text/poppler:0= )
+ postscript? ( app-text/libspectre:0= )
+ webp? ( media-libs/libwebp:0= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+doecho() {
+ echo "$@"
+ "$@" || die
+}
+
+pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~INOTIFY_USER"
+ linux-info_pkg_setup
+ fi
+}
+
+src_configure() {
+ local backends="gdkpixbuf"
+ use archive && backends+=",archive,archive_cbx"
+ use ffmpeg || use libav && backends+=",libav"
+ use imagemagick && backends+=",wand"
+ use pdf && backends+=",poppler"
+ use postscript && backends+=",spectre"
+ use webp && backends+=",webp"
+
+ doecho ./configure \
+ --backends-build=shared \
+ --backends=${backends} \
+ --prefix="${EPREFIX}/usr" \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --destdir="${ED}"
+}
+
+src_compile() {
+ tc-export CC
+ emake VERBOSE=1 CFLAGS="${CFLAGS}"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}