summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJiayi Zhao <jeff.no.zhao@gmail.com>2018-01-14 10:48:48 -0500
committerMichał Górny <mgorny@gentoo.org>2018-03-13 08:41:43 +0100
commit1ea23f10d0bc7b27c925ac9a5375ea9ea126331c (patch)
tree6b8f50eccf330387856f904880dae12c58149375 /media-gfx/qimgv/qimgv-9999.ebuild
parenttoolchain.eclass: Use :0= for dependency on >=dev-libs/isl-0.14. (diff)
downloadgentoo-1ea23f10d0bc7b27c925ac9a5375ea9ea126331c.tar.gz
gentoo-1ea23f10d0bc7b27c925ac9a5375ea9ea126331c.tar.bz2
gentoo-1ea23f10d0bc7b27c925ac9a5375ea9ea126331c.zip
media-gfx/qimgv: new package
Closes: https://github.com/gentoo/gentoo/pull/6858
Diffstat (limited to 'media-gfx/qimgv/qimgv-9999.ebuild')
-rw-r--r--media-gfx/qimgv/qimgv-9999.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-gfx/qimgv/qimgv-9999.ebuild b/media-gfx/qimgv/qimgv-9999.ebuild
new file mode 100644
index 000000000000..a5955797418a
--- /dev/null
+++ b/media-gfx/qimgv/qimgv-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit git-r3 cmake-utils gnome2-utils xdg-utils
+
+DESCRIPTION="A cross-platform image viewer with webm support. Written in qt5."
+HOMEPAGE="https://github.com/easymodo/qimgv"
+
+EGIT_REPO_URI="https://github.com/easymodo/qimgv.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ media-video/mpv[libmpv]
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}