summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-07-12 21:23:06 +0100
committerSam James <sam@gentoo.org>2024-07-12 21:23:18 +0100
commitc15580624df737dd8363b38ed59ac9018aa3def7 (patch)
treeab7ae814cba486dc29403566859c592c467bd5c8 /media-gfx
parentsci-chemistry/autodock_vina: fix build w/ boost-1.85 (diff)
downloadgentoo-c15580624df737dd8363b38ed59ac9018aa3def7.tar.gz
gentoo-c15580624df737dd8363b38ed59ac9018aa3def7.tar.bz2
gentoo-c15580624df737dd8363b38ed59ac9018aa3def7.zip
media-gfx/sfftobmp: fix build w/ boost-1.85
Closes: https://bugs.gentoo.org/932281 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/sfftobmp/files/sfftobmp-3.1.2-boost-1.85.patch63
-rw-r--r--media-gfx/sfftobmp/sfftobmp-3.1.2-r3.ebuild11
2 files changed, 67 insertions, 7 deletions
diff --git a/media-gfx/sfftobmp/files/sfftobmp-3.1.2-boost-1.85.patch b/media-gfx/sfftobmp/files/sfftobmp-3.1.2-boost-1.85.patch
new file mode 100644
index 000000000000..9fac13880922
--- /dev/null
+++ b/media-gfx/sfftobmp/files/sfftobmp-3.1.2-boost-1.85.patch
@@ -0,0 +1,63 @@
+https://www.boost.org/doc/libs/1_85_0/libs/filesystem/doc/deprecated.html
+--- a/src/cmdline.cpp
++++ b/src/cmdline.cpp
+@@ -41,7 +41,6 @@
+ #include <iostream>
+
+ #include <boost/filesystem/operations.hpp>
+-#include <boost/filesystem/convenience.hpp>
+
+ #include <tiff.h>
+
+--- a/src/main.cpp
++++ b/src/main.cpp
+@@ -41,7 +41,6 @@
+
+ #include <boost/filesystem/path.hpp>
+ #include <boost/filesystem/operations.hpp>
+-#include <boost/filesystem/convenience.hpp>
+
+ extern "C"
+ {
+@@ -172,10 +171,10 @@ int main( int argc, char *argv[] )
+ if (pathOutFileName.string().length()) {
+ // A fixed name was given, so use it as a base name
+ outPath = pathOutFileName;
+- std::string orgExt = fs::extension(outPath);
++ std::string orgExt = outPath.extension().string();
+ if (nFileCountOut > 1) {
+ sprintf(acNumber, "_%03d", nPage+1);
+- outPath = fs::change_extension(outPath, acNumber);
++ outPath.replace_extension(acNumber);
+ if (orgExt.length()) {
+ std::string strTemp = outPath.string();
+ strTemp += orgExt;
+@@ -184,15 +183,15 @@ int main( int argc, char *argv[] )
+ }
+ } else {
+ // Otherwise construct output filename from input filename
+- outPath = pathOutDirectory / pathInFileName.leaf();
++ outPath = pathOutDirectory / pathInFileName.filename();
+ if (nFileCountOut > 1) {
+ sprintf(acNumber, "_%03d", nPage+1);
+- outPath = fs::change_extension(outPath, acNumber);
++ outPath.replace_extension(acNumber);
+ std::string strTemp = outPath.string();
+ strTemp += pOut->GetExtension();
+ outPath = fs::path(strTemp);
+ } else {
+- outPath = fs::change_extension(outPath, pOut->GetExtension());
++ outPath.replace_extension(pOut->GetExtension());
+ }
+ }
+ if (!proc.doOverwrite() && !((nPage > 0) && (nFileCountOut == 1)) && fs::exists(outPath)) {
+--- a/src/output.cpp
++++ b/src/output.cpp
+@@ -42,7 +42,6 @@
+ #include <iostream>
+
+ #include <boost/filesystem/path.hpp>
+-#include <boost/filesystem/convenience.hpp>
+
+ #ifdef WIN32
+ #include <io.h>
diff --git a/media-gfx/sfftobmp/sfftobmp-3.1.2-r3.ebuild b/media-gfx/sfftobmp/sfftobmp-3.1.2-r3.ebuild
index 236b6a7b496a..6b9a92e6cfc2 100644
--- a/media-gfx/sfftobmp/sfftobmp-3.1.2-r3.ebuild
+++ b/media-gfx/sfftobmp/sfftobmp-3.1.2-r3.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools flag-o-matic
+inherit autotools
MY_P=${PN}${PV//./_}
@@ -19,7 +19,8 @@ KEYWORDS="amd64 ~hppa ppc x86"
RDEPEND="
dev-libs/boost:=
media-libs/libjpeg-turbo:=
- media-libs/tiff:="
+ media-libs/tiff:=
+"
DEPEND="${RDEPEND}"
BDEPEND="app-arch/unzip"
@@ -27,6 +28,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-3.1.1-gcc44-and-boost-1_37.patch
"${FILESDIR}"/${PN}-3.1.2-boost_fs3.patch
"${FILESDIR}"/${PN}-3.1.2-Wformat.patch
+ "${FILESDIR}"/${PN}-3.1.2-boost-1.85.patch
)
src_prepare() {
@@ -34,11 +36,6 @@ src_prepare() {
eautoreconf
}
-src_configure() {
- append-cppflags -DBOOST_FILESYSTEM_VERSION=3
- default
-}
-
src_install() {
default
dodoc doc/{changes,credits,readme}