summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2022-06-23 17:44:14 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-06-24 09:39:03 +0300
commit765d034f0f642cdce37aa38be60defa5095ee065 (patch)
treeb6ac3a78a2aaf1e68532fa7a818dacb345e37407 /media-libs/assimp/assimp-5.2.3.ebuild
parentdev-lang/python: Stabilize 3.9.13 hppa, #852599 (diff)
downloadgentoo-765d034f0f642cdce37aa38be60defa5095ee065.tar.gz
gentoo-765d034f0f642cdce37aa38be60defa5095ee065.tar.bz2
gentoo-765d034f0f642cdce37aa38be60defa5095ee065.zip
media-libs/assimp: drop 5.0.1, 5.2.2, 5.2.3
Closes: https://bugs.gentoo.org/835089 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/26058 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-libs/assimp/assimp-5.2.3.ebuild')
-rw-r--r--media-libs/assimp/assimp-5.2.3.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/media-libs/assimp/assimp-5.2.3.ebuild b/media-libs/assimp/assimp-5.2.3.ebuild
deleted file mode 100644
index d74e3f10d1f0..000000000000
--- a/media-libs/assimp/assimp-5.2.3.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Importer library to import assets from 3D files"
-HOMEPAGE="https://github.com/assimp/assimp"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
-IUSE="samples test"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/boost:=
- sys-libs/zlib[minizip]
- samples? (
- media-libs/freeglut
- virtual/opengl
- x11-libs/libX11
- )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- test? ( dev-cpp/gtest )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-5.2.2-fix-usage-of-incompatible-minizip-data-structure.patch
- "${FILESDIR}"/${P}-drop-Werror-gcc-option.patch
- "${FILESDIR}"/${PN}-5.2.2-disable-failing-tests.patch
-)
-
-DOCS=( CodeConventions.md Readme.md )
-
-src_prepare() {
- if use x86 ; then
- eapply "${FILESDIR}"/${P}-drop-failing-tests-for-abi_x86_32.patch
- fi
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DASSIMP_ASAN=OFF
- -DASSIMP_BUILD_DOCS=OFF
- -DASSIMP_BUILD_SAMPLES=$(usex samples)
- -DASSIMP_BUILD_TESTS=$(usex test)
- -DASSIMP_ERROR_MAX=ON
- -DASSIMP_INJECT_DEBUG_POSTFIX=OFF
- -DASSIMP_IGNORE_GIT_HASH=ON
- -DASSIMP_UBSAN=OFF
- )
-
- if use samples; then
- mycmakeargs+=( -DOpenGL_GL_PREFERENCE="GLVND" )
- fi
-
- cmake_src_configure
-}
-
-src_test() {
- "${BUILD_DIR}/bin/unit" || die
-}