summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-01-08 00:10:43 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-01-09 18:28:08 +0100
commitbeeee9831132febf0c95d5b14b3171aee20a696b (patch)
tree138ad75cb841eba789b5c4ed955944907ebce1af /media-libs/avidemux-plugins
parentmedia-video/avidemux: Sorting, line breaks (diff)
downloadgentoo-beeee9831132febf0c95d5b14b3171aee20a696b.tar.gz
gentoo-beeee9831132febf0c95d5b14b3171aee20a696b.tar.bz2
gentoo-beeee9831132febf0c95d5b14b3171aee20a696b.zip
media-libs/avidemux-plugins: Sorting, style fixes
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'media-libs/avidemux-plugins')
-rw-r--r--media-libs/avidemux-plugins/avidemux-plugins-9999.ebuild32
1 files changed, 15 insertions, 17 deletions
diff --git a/media-libs/avidemux-plugins/avidemux-plugins-9999.ebuild b/media-libs/avidemux-plugins/avidemux-plugins-9999.ebuild
index 02d96ecd4adb..c39414c1f978 100644
--- a/media-libs/avidemux-plugins/avidemux-plugins-9999.ebuild
+++ b/media-libs/avidemux-plugins/avidemux-plugins-9999.ebuild
@@ -1,25 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit cmake-utils python-single-r1
-
-DESCRIPTION="Plugins for the video editor media-video/avidemux"
-HOMEPAGE="http://fixounet.free.fr/avidemux"
-
-# Multiple licenses because of all the bundled stuff.
-LICENSE="GPL-1 GPL-2 MIT PSF-2 public-domain"
-SLOT="2.6"
-IUSE="aac aften a52 alsa amr dcaenc debug dts fdk fontconfig fribidi jack lame libsamplerate cpu_flags_x86_mmx opengl nvenc opus oss pulseaudio qt5 vorbis truetype twolame xv xvid x264 x265 vdpau vpx"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="https://github.com/mean00/avidemux2.git"
EGIT_CHECKOUT_DIR=${WORKDIR}
-
inherit git-r3
else
MY_PN="${PN/-plugins/}"
@@ -27,6 +13,17 @@ else
SRC_URI="mirror://sourceforge/${MY_PN}/${MY_PN}/${PV}/${MY_P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
+PYTHON_COMPAT=( python2_7 )
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="Plugins for the video editor media-video/avidemux"
+HOMEPAGE="http://fixounet.free.fr/avidemux"
+
+# Multiple licenses because of all the bundled stuff.
+LICENSE="GPL-1 GPL-2 MIT PSF-2 public-domain"
+SLOT="2.6"
+IUSE="a52 aac aften alsa amr dcaenc debug dts fdk fontconfig fribidi jack lame libsamplerate cpu_flags_x86_mmx nvenc opengl opus oss pulseaudio qt5 truetype twolame vdpau vorbis vpx x264 x265 xv xvid"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
~media-libs/avidemux-core-${PV}:${SLOT}[vdpau?]
@@ -73,7 +70,8 @@ RDEPEND="${PYTHON_DEPS}
vpx? ( media-libs/libvpx:0= )
"
DEPEND="${RDEPEND}
- oss? ( virtual/os-headers:0 )"
+ oss? ( virtual/os-headers:0 )
+"
S="${WORKDIR}/${MY_P}"
@@ -82,7 +80,7 @@ PATCHES=( "${FILESDIR}"/${PN}-2.6.20-optional-pulse.patch )
src_prepare() {
default
- #Don't reapply PATCHES during cmake-utils_src_prepare
+ # Don't reapply PATCHES during cmake-utils_src_prepare
unset PATCHES
processes="buildPluginsCommon:avidemux_plugins