summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-05-31 16:47:09 +0100
committerJames Le Cuirot <chewi@gentoo.org>2020-05-31 17:19:31 +0100
commit8b9daec6431c853fbdbd944fef316b603c5514ce (patch)
treeeae48aa8f63c748b3db50d5d9e7d5bee9232264d /media-libs/dumb/dumb-2.0.3.ebuild
parentdev-libs/libuv: s390 stable wrt bug #716822 (diff)
downloadgentoo-8b9daec6431c853fbdbd944fef316b603c5514ce.tar.gz
gentoo-8b9daec6431c853fbdbd944fef316b603c5514ce.tar.bz2
gentoo-8b9daec6431c853fbdbd944fef316b603c5514ce.zip
media-libs/dumb: Bump to 2.0.3, EAPI 7, new upstream
This adds an allegro USE flag to replace the media-libs/aldumb package. Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-libs/dumb/dumb-2.0.3.ebuild')
-rw-r--r--media-libs/dumb/dumb-2.0.3.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/media-libs/dumb/dumb-2.0.3.ebuild b/media-libs/dumb/dumb-2.0.3.ebuild
new file mode 100644
index 000000000000..7c509445721b
--- /dev/null
+++ b/media-libs/dumb/dumb-2.0.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="Module/tracker based music format parser and player library"
+HOMEPAGE="https://github.com/kode54/dumb"
+SRC_URI="https://github.com/kode54/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="DUMB-0.9.3"
+SLOT="0/2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="allegro cpu_flags_x86_sse examples"
+
+RDEPEND="
+ allegro? (
+ media-libs/allegro:0[${MULTILIB_USEDEP}]
+ !media-libs/aldumb
+ )
+ examples? (
+ >=dev-libs/argtable-2
+ media-libs/libsdl2[sound]
+ )
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-pkg-config.patch
+)
+
+DOCS=(
+ CHANGELOG.md
+ DUMBFILE_SYSTEM.md
+ README.md
+ UPDATING_YOUR_PROJECTS.md
+)
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_ALLEGRO4=$(usex allegro)
+ -DBUILD_EXAMPLES=$(multilib_native_usex examples)
+ -DUSE_SSE=$(usex cpu_flags_x86_sse)
+ )
+ cmake_src_configure
+}