summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-26 17:20:27 +0000
committerSam James <sam@gentoo.org>2021-01-26 17:21:11 +0000
commit2e15facc8941344ea63c3089eb3b3d63fd636041 (patch)
tree4ffd02bfa35547cc70e3a182ba87e5e6f11e6821 /media-libs/gd
parentwww-apps/jekyll: drop patch and bump watch dep (diff)
downloadgentoo-2e15facc8941344ea63c3089eb3b3d63fd636041.tar.gz
gentoo-2e15facc8941344ea63c3089eb3b3d63fd636041.tar.bz2
gentoo-2e15facc8941344ea63c3089eb3b3d63fd636041.zip
media-libs/gd: enable jpeg, png by default
* Default change matches upstream defaults (libpng and libjpeg are on most systems anyway, and dependencies of media-libs/gd often enable one or both of these flags). * Needed for tests and mark this in REQUIRED_USE. Closes: https://bugs.gentoo.org/767313 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/gd')
-rw-r--r--media-libs/gd/gd-2.3.0.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/media-libs/gd/gd-2.3.0.ebuild b/media-libs/gd/gd-2.3.0.ebuild
index 04480d159c33..4824a477708f 100644
--- a/media-libs/gd/gd-2.3.0.ebuild
+++ b/media-libs/gd/gd-2.3.0.ebuild
@@ -8,16 +8,21 @@ inherit autotools flag-o-matic multilib-minimal
DESCRIPTION="Graphics library for fast image creation"
HOMEPAGE="https://libgd.org/ https://www.boutell.com/gd/"
SRC_URI="https://github.com/libgd/libgd/releases/download/${P}/lib${P}.tar.xz"
+S="${WORKDIR}/lib${P}"
LICENSE="gd IJG HPND BSD"
SLOT="2/3"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="cpu_flags_x86_sse fontconfig jpeg png static-libs test tiff truetype webp xpm zlib"
+IUSE="cpu_flags_x86_sse fontconfig +jpeg +png static-libs test tiff truetype webp xpm zlib"
RESTRICT="!test? ( test )"
# fontconfig has prefixed font paths, details see bug #518970
-REQUIRED_USE="prefix? ( fontconfig )"
+REQUIRED_USE="
+ prefix? ( fontconfig )
+ test? ( png )
+"
+BDEPEND="virtual/pkgconfig"
RDEPEND="fontconfig? ( >=media-libs/fontconfig-2.10.92[${MULTILIB_USEDEP}] )
jpeg? ( >=virtual/jpeg-0-r2:0=[${MULTILIB_USEDEP}] )
png? ( >=media-libs/libpng-1.6.10:0=[${MULTILIB_USEDEP}] )
@@ -26,10 +31,7 @@ RDEPEND="fontconfig? ( >=media-libs/fontconfig-2.10.92[${MULTILIB_USEDEP}] )
webp? ( media-libs/libwebp:=[${MULTILIB_USEDEP}] )
xpm? ( >=x11-libs/libXpm-3.5.10-r1[${MULTILIB_USEDEP}] >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}] )
zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S="${WORKDIR}/lib${P}"
+DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}/${PN}-2.3.0-disable-flaky-tests.patch"