summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-11-08 18:42:03 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2015-11-08 19:08:35 +0100
commit60a4b062bc7aad5ee14b941355210f1c8ea01b05 (patch)
treefc7c39d434bedb1e754a5b8570189d567c804ad2 /media-libs/gst-plugins-ugly
parentmedia-plugins/gst-plugins-voamrwbenc: version bump to 1.6.1 (diff)
downloadgentoo-60a4b062bc7aad5ee14b941355210f1c8ea01b05.tar.gz
gentoo-60a4b062bc7aad5ee14b941355210f1c8ea01b05.tar.bz2
gentoo-60a4b062bc7aad5ee14b941355210f1c8ea01b05.zip
media-libs/gst-plugins-ugly: version bump to 1.6.1
Use ${PV} for gstreamer and gst-plugins-base dependency as all releases are coordinated for a while now. Package-Manager: portage-2.2.23
Diffstat (limited to 'media-libs/gst-plugins-ugly')
-rw-r--r--media-libs/gst-plugins-ugly/Manifest1
-rw-r--r--media-libs/gst-plugins-ugly/gst-plugins-ugly-1.6.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-ugly/Manifest b/media-libs/gst-plugins-ugly/Manifest
index ba8aa210d826..fe6a50e8439d 100644
--- a/media-libs/gst-plugins-ugly/Manifest
+++ b/media-libs/gst-plugins-ugly/Manifest
@@ -2,3 +2,4 @@ DIST gst-plugins-ugly-0.10.19.tar.xz 882452 SHA256 4934f65ff892637e7efaf1cfe6357
DIST gst-plugins-ugly-1.2.4.tar.xz 844968 SHA256 4ef6f76a47d57b8385d457c7b620b4c28fc041ab1d7c2e3e2f5f05b12b988ea8 SHA512 91a9d950e73a8d6c8bb4c559ba8f4a4dffc163be714d93c0d0d6421f2c9932a4b1af665f76417e79b50b31c83d8a766df9cf6c337b8371371708efc8683e24e1 WHIRLPOOL c1c3885cf2e041c4427f30ca13cda2948b8a35273d3e6417bfe83566f03230208ce1e019e655ae2c98725e94cce6c7fb37b450307312f682bdbd7c948190e7c0
DIST gst-plugins-ugly-1.4.5.tar.xz 846828 SHA256 5cd5e81cf618944f4dc935f1669b2125e8bb2fe9cc7dc8dc15b72237aca49067 SHA512 9353a5b9492758d8255fcab23c0eb170ec31e884774c22915b57cc4a2ed56bad61643d7bd44fcdb919e7ad9b2023d1d0fab23f9c9fda1cb2b9883c92ec6b6fc0 WHIRLPOOL b212a4dcba654dac7866ad75551b26818349780b0d7905e63c45b75e21ffbb86ae0f4e9e79ef8bfb317149c2d4f01cbda2c6e2cf2cbcf58991bc09ba9aa85f4e
DIST gst-plugins-ugly-1.6.0.tar.xz 859996 SHA256 91178dc0d687a83c083190a905681d3a66901374b1004fc52cd300b7802e5f06 SHA512 72fadf593d3307b04757763ea7cec00c8c4f1d1aa7ab68a0876e7888f63b995b81b2d5efe6ac45a4dd068c0cfa9ea23b7a6b4435666bcd36b42e174b068874f0 WHIRLPOOL 3ad574a2d74591de9ecb0167bdea29478f48b7fe2cf4a1fec83ece5d0189d66826f1793e84215d7f412245b5b290310c500fea6a67cfcde94358da3884edeb57
+DIST gst-plugins-ugly-1.6.1.tar.xz 859200 SHA256 0cc3f90e4322efe1f774272e8fe5c185be37cf7999cd5ca7e0e0607e03d56a57 SHA512 f62eb68779b6bbcc555f43c7c9f4a034f0fabe9244161d9c5ffd410c64a56c915637f5d4ec974810acd67fc744b9a143ba46b6ace96daa2ab56703b1e954c2a0 WHIRLPOOL 8bf8d4295054b8346c08794bddf081da668cd6d9e0e3320381fd2f3a52eb8ffbfa12e0a847137a7cde94de51ebf3bcecee17a098581d63ce444d52a42af76264
diff --git a/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.6.1.ebuild b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.6.1.ebuild
new file mode 100644
index 000000000000..fa707c40f566
--- /dev/null
+++ b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.6.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GST_ORG_MODULE="gst-plugins-ugly"
+
+inherit eutils flag-o-matic gstreamer
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="+orc"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+"
+
+multilib_src_configure() {
+ gstreamer_multilib_src_configure
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/plugins/html docs/plugins/html || die
+ fi
+
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+ einstalldocs
+ prune_libtool_files --modules
+}