summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2022-04-07 10:17:02 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-04-15 09:18:48 +0300
commit2d60a5f2a86aeaaa6a4091d988cfca9e2b8755b3 (patch)
tree3256ec48f92e362472cb0987b9b0f5fb15bdd2a4 /media-libs/ilmbase/ilmbase-2.5.8.ebuild
parentapp-shells/gentoo-zsh-completions: update EAPI 6 -> 8 (diff)
downloadgentoo-2d60a5f2a86aeaaa6a4091d988cfca9e2b8755b3.tar.gz
gentoo-2d60a5f2a86aeaaa6a4091d988cfca9e2b8755b3.tar.bz2
gentoo-2d60a5f2a86aeaaa6a4091d988cfca9e2b8755b3.zip
media-libs/ilmbase: bump to 2.5.8
Bug: https://bugs.gentoo.org/837062 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-libs/ilmbase/ilmbase-2.5.8.ebuild')
-rw-r--r--media-libs/ilmbase/ilmbase-2.5.8.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-libs/ilmbase/ilmbase-2.5.8.ebuild b/media-libs/ilmbase/ilmbase-2.5.8.ebuild
new file mode 100644
index 000000000000..04019509e220
--- /dev/null
+++ b/media-libs/ilmbase/ilmbase-2.5.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="OpenEXR ILM Base libraries"
+HOMEPAGE="https://www.openexr.com/"
+SRC_URI="https://github.com/AcademySoftwareFoundation/openexr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/openexr-${PV}/IlmBase"
+
+LICENSE="BSD"
+SLOT="0/25" # based on SONAME
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+IUSE="large-stack static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="!media-libs/openexr:3"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( README.md )
+
+src_prepare() {
+ if use abi_x86_32 && use test; then
+ eapply "${FILESDIR}"/${PN}-2.5.4-0001-disable-failing-test-on-x86_32.patch
+ fi
+
+ multilib_foreach_abi cmake_src_prepare
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ -DILMBASE_BUILD_BOTH_STATIC_SHARED=$(usex static-libs)
+ -DILMBASE_ENABLE_LARGE_STACK=$(usex large-stack)
+ -DILMBASE_INSTALL_PKG_CONFIG=ON
+ )
+
+ cmake_src_configure
+}