summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Flogeras <dflogeras2@gmail.com>2023-05-24 06:42:48 -0300
committerJoonas Niilola <juippis@gentoo.org>2023-05-28 15:20:28 +0300
commit214c035be74df50726a826a8c42af13cda4fcc4d (patch)
tree3e65ab9b9137eb7f61e625bcf6b780c4cbe00682 /media-libs/kimageannotator/kimageannotator-0.6.1.ebuild
parentsys-apps/hd-idle: drop 1.05-r1 (diff)
downloadgentoo-214c035be74df50726a826a8c42af13cda4fcc4d.tar.gz
gentoo-214c035be74df50726a826a8c42af13cda4fcc4d.tar.bz2
gentoo-214c035be74df50726a826a8c42af13cda4fcc4d.zip
media-libs/kimageannotator: 0.6.1 bump
Closes: https://bugs.gentoo.org/907269 Closes: https://github.com/gentoo/gentoo/pull/31193 Signed-off-by: David Flogeras <dflogeras2@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-libs/kimageannotator/kimageannotator-0.6.1.ebuild')
-rw-r--r--media-libs/kimageannotator/kimageannotator-0.6.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/media-libs/kimageannotator/kimageannotator-0.6.1.ebuild b/media-libs/kimageannotator/kimageannotator-0.6.1.ebuild
new file mode 100644
index 000000000000..ceddbc0c348d
--- /dev/null
+++ b/media-libs/kimageannotator/kimageannotator-0.6.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VIRTUALX_REQUIRED="test"
+inherit cmake virtualx
+
+MY_PN=kImageAnnotator
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tool for annotating images"
+HOMEPAGE="https://github.com/ksnip/kImageAnnotator"
+SRC_URI="https://github.com/ksnip/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5[png]
+ >=media-libs/kcolorpicker-0.2.0
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-qt/qttest:5
+ dev-cpp/gtest
+ )
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ BUILD_DIR="${BUILD_DIR}/tests" virtx cmake_src_test
+}