summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libreplaygain
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libreplaygain')
-rw-r--r--media-libs/libreplaygain/Manifest1
-rw-r--r--media-libs/libreplaygain/libreplaygain-477-r1.ebuild30
-rw-r--r--media-libs/libreplaygain/libreplaygain-477.ebuild28
-rw-r--r--media-libs/libreplaygain/metadata.xml5
4 files changed, 64 insertions, 0 deletions
diff --git a/media-libs/libreplaygain/Manifest b/media-libs/libreplaygain/Manifest
new file mode 100644
index 000000000000..4f85c75059fb
--- /dev/null
+++ b/media-libs/libreplaygain/Manifest
@@ -0,0 +1 @@
+DIST libreplaygain-477.tar.xz 8272 SHA256 b7fe1b28950512014e561e7fbcae2a075148ac70aa356002ca6ee806bc6934bf SHA512 9e81deb237e35e63d67efabcbfe40f5a6fd34f4a6b0239a21e6ab8ba3c9ca172297cf323fbc4ada749dcfcdf0b711c354e39f12af9a9576900384c441657ff8e WHIRLPOOL c5ad7ab500521c8ede792282429627037a2e9d9805d727450c3eeea9ed801d27fe2e5f075aa17d0bd3425ea6edde06eb0d99a784bbeae00c80b6cc1b46b6e791
diff --git a/media-libs/libreplaygain/libreplaygain-477-r1.ebuild b/media-libs/libreplaygain/libreplaygain-477-r1.ebuild
new file mode 100644
index 000000000000..591d18a81358
--- /dev/null
+++ b/media-libs/libreplaygain/libreplaygain-477-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-multilib
+
+# svn export http://svn.musepack.net/libreplaygain libreplaygain-${PV}
+# tar -cJf libreplaygain-${PV}.tar.xz libreplaygain-${PV}
+
+DESCRIPTION="Replay Gain library from Musepack"
+HOMEPAGE="http://www.musepack.net/"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+RDEPEND="abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r2
+ !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
+
+src_prepare() {
+ sed -i -e '/CMAKE_C_FLAGS/d' CMakeLists.txt || die
+}
+
+src_install() {
+ cmake-multilib_src_install
+ insinto /usr/include
+ doins -r include/replaygain
+}
diff --git a/media-libs/libreplaygain/libreplaygain-477.ebuild b/media-libs/libreplaygain/libreplaygain-477.ebuild
new file mode 100644
index 000000000000..628b9a7fdfce
--- /dev/null
+++ b/media-libs/libreplaygain/libreplaygain-477.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit cmake-utils
+
+# svn export http://svn.musepack.net/libreplaygain libreplaygain-${PV}
+# tar -cJf libreplaygain-${PV}.tar.xz libreplaygain-${PV}
+
+DESCRIPTION="Replay Gain library from Musepack"
+HOMEPAGE="http://www.musepack.net/"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ sed -i -e '/CMAKE_C_FLAGS/d' CMakeLists.txt || die
+}
+
+src_install() {
+ cmake-utils_src_install
+ insinto /usr/include
+ doins -r include/replaygain
+}
diff --git a/media-libs/libreplaygain/metadata.xml b/media-libs/libreplaygain/metadata.xml
new file mode 100644
index 000000000000..ae573a60407f
--- /dev/null
+++ b/media-libs/libreplaygain/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+</pkgmetadata>