summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Zander <negril.nx+gentoo@gmail.com>2023-12-08 15:19:31 +0100
committerSam James <sam@gentoo.org>2024-01-10 12:32:47 +0000
commit37b36ebe7590724945eb825714dbe5c8fe36b7d5 (patch)
tree72e792688a1332de63f2553c9d1d56d8faa21a61 /media-libs/partio
parentmedia-gfx/alembic: disable py3.9 (diff)
downloadgentoo-37b36ebe7590724945eb825714dbe5c8fe36b7d5.tar.gz
gentoo-37b36ebe7590724945eb825714dbe5c8fe36b7d5.tar.bz2
gentoo-37b36ebe7590724945eb825714dbe5c8fe36b7d5.zip
media-libs/partio: add 1.17.1
Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/34219 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/partio')
-rw-r--r--media-libs/partio/Manifest1
-rw-r--r--media-libs/partio/partio-1.17.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/media-libs/partio/Manifest b/media-libs/partio/Manifest
index 35de8c8465ba..859d45911c02 100644
--- a/media-libs/partio/Manifest
+++ b/media-libs/partio/Manifest
@@ -1 +1,2 @@
DIST partio-1.14.6.tar.gz 336527 BLAKE2B 60c9c6ad9d5a7b58967e7633180d4f8d399bd129cc7b76fc4329b3d191ce0d381df7f977d5ec11ccedbdbcd8afa0fde2f946960f08a242338c2f674b4c94343e SHA512 5479d00b3124e8e06abbc65b1cdc01cdac37b9207c0615029e488baa0835e4ad545be2fb07dda5b4541dd846115059aaca5950ff904bddec6bb1fd72180ebcc0
+DIST partio-1.17.1.tar.gz 338461 BLAKE2B 6c08d5b74db34ce114206ab92332e42e827d537d83e65597ba777344e1b9dc69f9b57153f716e87df6955b9898cedcd7e6da353db111463d7c8bd47f648cca6a SHA512 5dbbd988c76a26ac6f3024e29ed12f37f7995daf211e065b9ffaf185c6203be7d9de48bd62b5955d2f5444af72fb3306ea5a0f3501cb0a49a26f157bb09ec6bc
diff --git a/media-libs/partio/partio-1.17.1.ebuild b/media-libs/partio/partio-1.17.1.ebuild
new file mode 100644
index 000000000000..69d97eac7f7c
--- /dev/null
+++ b/media-libs/partio/partio-1.17.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit cmake python-single-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/wdas/partio.git"
+else
+ SRC_URI="https://github.com/wdas/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Library for particle IO and manipulation"
+HOMEPAGE="https://partio.us/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ media-libs/freeglut
+ media-libs/glu
+ sys-libs/zlib
+ virtual/opengl
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ dev-lang/swig
+ doc? (
+ app-doc/doxygen
+ dev-texlive/texlive-bibtexextra
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package doc Doxygen)
+ )
+ cmake_src_configure
+}