summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-18 01:49:35 -0400
committerSam James <sam@gentoo.org>2024-03-18 07:20:18 +0000
commitcdf02b67d95801d2437d69fc30badbd16620999b (patch)
tree8dd796d6dd609947f356779294fe825c2555cfe5 /media-libs/sdl-ttf/sdl-ttf-2.0.11_p20220525.ebuild
parentgames-roguelike/scourge: update EAPI 7 -> 8 (diff)
downloadgentoo-cdf02b67d95801d2437d69fc30badbd16620999b.tar.gz
gentoo-cdf02b67d95801d2437d69fc30badbd16620999b.tar.bz2
gentoo-cdf02b67d95801d2437d69fc30badbd16620999b.zip
media-libs/sdl-ttf: make sure elibtoolize is applied
Since the libtool available is very old, that means running a full eautoreconf. Needed to e.g. pass LTO warning flags through to the linker. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/sdl-ttf/sdl-ttf-2.0.11_p20220525.ebuild')
-rw-r--r--media-libs/sdl-ttf/sdl-ttf-2.0.11_p20220525.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/media-libs/sdl-ttf/sdl-ttf-2.0.11_p20220525.ebuild b/media-libs/sdl-ttf/sdl-ttf-2.0.11_p20220525.ebuild
index e8e9238c0a86..6b7b276efe6a 100644
--- a/media-libs/sdl-ttf/sdl-ttf-2.0.11_p20220525.ebuild
+++ b/media-libs/sdl-ttf/sdl-ttf-2.0.11_p20220525.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# Check SDL-1.2 branch for possible backports/new snapshots
-inherit multilib-minimal
+inherit autotools multilib-minimal
SDL_TTF_COMMIT="2648c22c4f9e32d05a11b32f636b1c225a1502ac"
@@ -28,6 +28,11 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
+src_prepare() {
+ default
+ eautoreconf
+}
+
multilib_src_configure() {
local myeconfargs=(
$(use_enable static-libs static)