summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-12-18 11:34:05 +0100
committerPacho Ramos <pacho@gentoo.org>2022-12-18 11:34:43 +0100
commite50a72cb82704d73bc3a34a01890679cb5ba4e43 (patch)
tree3e7ad2ccc0cc90dedd559c1dc54a6cffc0b1202b /media-libs/tse3
parentmedia-sound/sox: Don't use .la files, fix automagic dep (diff)
downloadgentoo-e50a72cb82704d73bc3a34a01890679cb5ba4e43.tar.gz
gentoo-e50a72cb82704d73bc3a34a01890679cb5ba4e43.tar.bz2
gentoo-e50a72cb82704d73bc3a34a01890679cb5ba4e43.zip
media-libs/tse3: Drop .la files
Closes: https://bugs.gentoo.org/847511 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'media-libs/tse3')
-rw-r--r--media-libs/tse3/tse3-0.3.1-r2.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/media-libs/tse3/tse3-0.3.1-r2.ebuild b/media-libs/tse3/tse3-0.3.1-r2.ebuild
new file mode 100644
index 000000000000..7733309ab188
--- /dev/null
+++ b/media-libs/tse3/tse3-0.3.1-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools flag-o-matic
+
+DESCRIPTION="TSE3 Sequencer library"
+HOMEPAGE="http://TSE3.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://gentoo/${P}-awe_voice.h.tbz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="alsa oss"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.2.7-size_t-64bit.patch"
+ "${FILESDIR}/${PN}-0.2.7-gcc4.patch"
+ "${FILESDIR}/${P}-parallelmake.patch"
+ "${FILESDIR}/${P}+gcc-4.3.patch"
+)
+
+src_prepare() {
+ default
+ mv configure.in configure.ac || die "Moving configure.in -> .ac failed"
+ if use oss; then
+ cp "${WORKDIR}"/awe_voice.h src/ || die "copy failed"
+ append-cppflags -DHAVE_AWE_VOICE_H
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ use alsa || myconf="${myconf} --without-alsa"
+ use oss || myconf="${myconf} --without-oss"
+
+ econf \
+ --without-doc-install \
+ --without-aRts \
+ ${myconf}
+}
+
+src_install() {
+ HTML_DOCS=( doc/*.{html,gif,png} )
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+ dodoc doc/History
+}