summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-14 01:19:34 +0100
committerSam James <sam@gentoo.org>2023-05-14 01:31:22 +0100
commit031e152dafaa74c07068f677c853b71b5f350ec1 (patch)
tree1a65e8e765ca5db7bef22b5c3b606602c0bc91bc /media-libs/vigra/vigra-9999.ebuild
parentsys-auth/sssd: drop invalid USE=valgrind flag (for test suite) (diff)
downloadgentoo-031e152dafaa74c07068f677c853b71b5f350ec1.tar.gz
gentoo-031e152dafaa74c07068f677c853b71b5f350ec1.tar.bz2
gentoo-031e152dafaa74c07068f677c853b71b5f350ec1.zip
media-libs/vigra: drop invalid USE=valgrind flag (for test suite)
We don't, in general, run Valgrind for test suites in Gentoo because it's not portable enough and gives inconsistent results, especially under sandbox. Plus it's confusing given USE=valgrind is effectively a global USE flag (even if it isn't in use.desc yet) for meaning "enable annotations to enable better debugging under Valgrind", rather than "run tests under it". Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/vigra/vigra-9999.ebuild')
-rw-r--r--media-libs/vigra/vigra-9999.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/media-libs/vigra/vigra-9999.ebuild b/media-libs/vigra/vigra-9999.ebuild
index 9d414e9529c7..5a2feab44ca9 100644
--- a/media-libs/vigra/vigra-9999.ebuild
+++ b/media-libs/vigra/vigra-9999.ebuild
@@ -20,7 +20,7 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="doc +fftw +hdf5 +jpeg mpi openexr +png +python test +tiff valgrind +zlib"
+IUSE="doc +fftw +hdf5 +jpeg mpi openexr +png +python test +tiff +zlib"
REQUIRED_USE="
python? ( hdf5 ${PYTHON_REQUIRED_USE} )
@@ -29,7 +29,6 @@ REQUIRED_USE="
BDEPEND="
test? (
>=dev-python/nose-1.1.2-r1[${PYTHON_USEDEP}]
- valgrind? ( dev-util/valgrind )
)
"
# runtime dependency on python is required by the vigra-config script
@@ -107,7 +106,7 @@ src_configure() {
-DDOCINSTALL="share/doc/${PF}/html"
-DWITH_HDF5=$(usex hdf5)
-DWITH_OPENEXR=$(usex openexr)
- -DWITH_VALGRIND=$(usex valgrind)
+ -DWITH_VALGRIND=OFF # only used for tests
-DWITH_VIGRANUMPY=$(usex python)
)
cmake_src_configure