summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2018-05-26 18:42:25 -0400
committerNick Sarnie <sarnex@gentoo.org>2018-05-26 18:58:30 -0400
commit3c713645a0c679996bd74717f99ff9f08ef129b1 (patch)
tree780f8f6327f5a8d2b1c160be983930131a127b3b /media-libs/vulkan-tools/vulkan-tools-9999.ebuild
parentmedia-libs/vulkan-layers: Initial version (diff)
downloadgentoo-3c713645a0c679996bd74717f99ff9f08ef129b1.tar.gz
gentoo-3c713645a0c679996bd74717f99ff9f08ef129b1.tar.bz2
gentoo-3c713645a0c679996bd74717f99ff9f08ef129b1.zip
media-libs/vulkan-tools: Initial version
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'media-libs/vulkan-tools/vulkan-tools-9999.ebuild')
-rw-r--r--media-libs/vulkan-tools/vulkan-tools-9999.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/media-libs/vulkan-tools/vulkan-tools-9999.ebuild b/media-libs/vulkan-tools/vulkan-tools-9999.ebuild
new file mode 100644
index 000000000000..d009fa4f314a
--- /dev/null
+++ b/media-libs/vulkan-tools/vulkan-tools-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-Tools.git"
+ EGIT_SUBMODULES=()
+ inherit git-r3
+else
+ EGIT_COMMIT="51dfb7b8a19820d6716190dd7e45cd6e861e1f1a"
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/KhronosGroup/Vulkan-Tools/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/Vulkan-Tools-${EGIT_COMMIT}"
+fi
+
+inherit python-any-r1 cmake-multilib
+
+DESCRIPTION="Official Vulkan Tools and Utilities for Windows, Linux, Android, and MacOS"
+HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Tools"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="X wayland"
+
+RDEPEND=""
+DEPEND="${PYTHON_DEPS}
+ dev-util/glslang:=[${MULTILIB_USEDEP}]
+ dev-util/vulkan-headers
+ wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
+ X? (
+ x11-libs/libX11:=[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr:=[${MULTILIB_USEDEP}]
+ )"
+
+PATCHES=( "${FILESDIR}/${PN}-Use-usr-for-vulkan-headers.patch" )
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_SKIP_RPATH=True
+ -DBUILD_WSI_MIR_SUPPORT=False
+ -DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
+ -DBUILD_WSI_XCB_SUPPORT=$(usex X)
+ -DBUILD_WSI_XLIB_SUPPORT=$(usex X)
+ -DGLSLANG_INSTALL_DIR="/usr"
+ )
+ cmake-utils_src_configure
+}