summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-12-09 23:01:50 +0000
committerJames Le Cuirot <chewi@gentoo.org>2022-12-09 23:01:50 +0000
commit844ac622c9eb129c5ba88a010f3d6bfc0289f16d (patch)
treec2c21d369c1c1c180ebb5b3f27f1af98871f2619 /media-libs
parentRevert "dev-vcs/git: Add missing runtime dependency on dev-perl/LWP-Protocol-... (diff)
downloadgentoo-844ac622c9eb129c5ba88a010f3d6bfc0289f16d.tar.gz
gentoo-844ac622c9eb129c5ba88a010f3d6bfc0289f16d.tar.bz2
gentoo-844ac622c9eb129c5ba88a010f3d6bfc0289f16d.zip
media-libs/vkroots: New package
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/vkroots/Manifest1
-rw-r--r--media-libs/vkroots/metadata.xml11
-rw-r--r--media-libs/vkroots/vkroots-0_p20221205.ebuild33
3 files changed, 45 insertions, 0 deletions
diff --git a/media-libs/vkroots/Manifest b/media-libs/vkroots/Manifest
new file mode 100644
index 000000000000..e0692c735e9b
--- /dev/null
+++ b/media-libs/vkroots/Manifest
@@ -0,0 +1 @@
+DIST vkroots-0_p20221205.tar.gz 272641 BLAKE2B ee61988cf1a110d39e96f027160cbefb2e3815e9ef60e367b54be94348d2cd75037a7eb115620460ed1c1c36256e919e568551258217e1b12aea760d2c90dd61 SHA512 a1a21f53d38385a5f300d9dd5650145074baad66b081beaab59179995afcc5a8df8adf19d52c5da15a7ee10fa530aa9d24c3ff1e04df3f7e1d3af526abc1e55e
diff --git a/media-libs/vkroots/metadata.xml b/media-libs/vkroots/metadata.xml
new file mode 100644
index 000000000000..853b3e8c417f
--- /dev/null
+++ b/media-libs/vkroots/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Joshua-Ashton/vkroots</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-libs/vkroots/vkroots-0_p20221205.ebuild b/media-libs/vkroots/vkroots-0_p20221205.ebuild
new file mode 100644
index 000000000000..639396330c56
--- /dev/null
+++ b/media-libs/vkroots/vkroots-0_p20221205.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit python-any-r1
+
+COMMIT="e6b89494142eec0ac6061f82a947d2f1246d3d7a"
+DESCRIPTION="Simple framework for writing Vulkan layers"
+HOMEPAGE="https://github.com/Joshua-Ashton/vkroots"
+SRC_URI="https://github.com/Joshua-Ashton/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+LICENSE="Apache-2.0 MIT LGPL-2.1"
+SLOT="0"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/vulkan-headers
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_compile() {
+ "${PYTHON}" ./gen/make_vkroots --xml "${BROOT}"/usr/share/vulkan/registry/vk.xml || die
+}
+
+src_install() {
+ default
+ insinto /usr/include/${PN}
+ doins ${PN}.h meson.build
+}