summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-09-03 18:58:28 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2024-09-04 11:36:45 +0200
commit8f1a81f22880f3254983185a9e61fc34f3c2a671 (patch)
tree4b661e10ed01cd477ce2837d4ccdc84aaaf826be /media-libs
parentmedia-libs/embree: add 3.14.5-r1, 4.3.1-r1 fix 938522 (diff)
downloadgentoo-8f1a81f22880f3254983185a9e61fc34f3c2a671.tar.gz
gentoo-8f1a81f22880f3254983185a9e61fc34f3c2a671.tar.bz2
gentoo-8f1a81f22880f3254983185a9e61fc34f3c2a671.zip
media-libs/fluidsynth-dssi: EAPI8 bump, fix LICENSE, fix bug #847400
Closes: https://bugs.gentoo.org/847400 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/38414 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/fluidsynth-dssi/fluidsynth-dssi-1.0.0-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/fluidsynth-dssi/fluidsynth-dssi-1.0.0-r2.ebuild b/media-libs/fluidsynth-dssi/fluidsynth-dssi-1.0.0-r2.ebuild
new file mode 100644
index 000000000000..9625b90cad74
--- /dev/null
+++ b/media-libs/fluidsynth-dssi/fluidsynth-dssi-1.0.0-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="DSSI Soft Synth Interface"
+HOMEPAGE="https://dssi.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/dssi/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="
+ media-libs/dssi
+ media-libs/liblo
+ media-sound/fluidsynth:=
+ x11-libs/gtk+:2
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-fluidsynth2.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}