summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-04-01 14:26:04 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-13 12:09:33 +0300
commita14366a5249f83ebd7f4a9124ccdbb507e04ed57 (patch)
tree29495f2cb5573e55578e744aed09ef516d20c404 /media-libs
parentapp-text/rnc2rng: add 2.7.0 (diff)
downloadgentoo-a14366a5249f83ebd7f4a9124ccdbb507e04ed57.tar.gz
gentoo-a14366a5249f83ebd7f4a9124ccdbb507e04ed57.tar.bz2
gentoo-a14366a5249f83ebd7f4a9124ccdbb507e04ed57.zip
media-libs/libmpris2client: EAPI8 bump, fix LICENSE
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/36039 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libmpris2client/libmpris2client-0.1.0-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-libs/libmpris2client/libmpris2client-0.1.0-r2.ebuild b/media-libs/libmpris2client/libmpris2client-0.1.0-r2.ebuild
new file mode 100644
index 000000000000..b85c77559762
--- /dev/null
+++ b/media-libs/libmpris2client/libmpris2client-0.1.0-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Library to control MPRIS2 compatible players"
+HOMEPAGE="https://github.com/matiasdelellis/libmpris2client"
+SRC_URI="https://github.com/matiasdelellis/${PN}/releases/download/V${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-libs/glib-2
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( AUTHORS NEWS README TODO )
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}