summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-06-14 13:24:19 -0400
committerMatt Turner <mattst88@gentoo.org>2023-06-14 13:26:54 -0400
commitb19fc2cad1025245feeba44f4aab23208694b9fb (patch)
tree4efec76321f41376f6e6b6e55a0c433da1968ce9 /media-libs
parentdev-python/contourpy: Keyword 1.1.0 riscv, #908478 (diff)
downloadgentoo-b19fc2cad1025245feeba44f4aab23208694b9fb.tar.gz
gentoo-b19fc2cad1025245feeba44f4aab23208694b9fb.tar.bz2
gentoo-b19fc2cad1025245feeba44f4aab23208694b9fb.zip
media-libs/gmmlib: Version bump to 22.3.7
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gmmlib/Manifest1
-rw-r--r--media-libs/gmmlib/gmmlib-22.3.7.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/gmmlib/Manifest b/media-libs/gmmlib/Manifest
index 757d45ddec59..fb279d3aaac3 100644
--- a/media-libs/gmmlib/Manifest
+++ b/media-libs/gmmlib/Manifest
@@ -1 +1,2 @@
DIST intel-gmmlib-22.3.5.tar.gz 843587 BLAKE2B 671f09a2be66962762dc47c8ab51dbc3454f197b2f8a8da73e09d1f1cef2284d69ca97ff78a6b9fd1c7c93baf0b5773a89e0e7fa22f7bf106e7205f0f681e5f4 SHA512 1440fd9afdf9bdb6b9ab45529ec48cd434d7a9410cbf026c3dc7dc60b09a8fa067993540b953c354805a766ff001ef56c756a4c37d465a2ca801f6cc179ca532
+DIST intel-gmmlib-22.3.7.tar.gz 845054 BLAKE2B 0a5c284bc5aa32a6b79d0e36689665b8fb6157765e26f33b7aef800e515c6dc26527c011512d633d5d6160463f9f16a720a4e23fcbc9bb35c853a25a41a339ec SHA512 145e54da5c80c6f750847c496146c5853f92b90d1fa66695140052e0264d884069a459cf27bea7b742f1ac10817c00a369067512b9f2666c8b3c6cadf0233a2e
diff --git a/media-libs/gmmlib/gmmlib-22.3.7.ebuild b/media-libs/gmmlib/gmmlib-22.3.7.ebuild
new file mode 100644
index 000000000000..21abbf34e428
--- /dev/null
+++ b/media-libs/gmmlib/gmmlib-22.3.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_BUILD_TYPE="Release"
+
+inherit cmake-multilib
+
+DESCRIPTION="Intel Graphics Memory Management Library"
+HOMEPAGE="https://github.com/intel/gmmlib"
+SRC_URI="https://github.com/intel/gmmlib/archive/intel-${P}.tar.gz"
+S="${WORKDIR}/${PN}-intel-${P}"
+
+KEYWORDS="~amd64"
+LICENSE="MIT"
+SLOT="0/12.3"
+IUSE="+custom-cflags test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20.2.2_conditional_testing.patch
+ "${FILESDIR}"/${PN}-20.3.2_cmake_project.patch
+ "${FILESDIR}"/${PN}-22.1.1_custom_cflags.patch
+)
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING="$(usex test)"
+ -DBUILD_TYPE="Release"
+ -DOVERRIDE_COMPILER_FLAGS="$(usex !custom-cflags)"
+ )
+
+ cmake_src_configure
+}