summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-23 07:39:59 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-23 08:09:50 +0100
commitcac9c9da2e4a2720b5932f8be2bcda8026dd90e5 (patch)
tree67f934976119f6a9161de0a277d6ea3be873cae1 /media-libs
parentdev-python/twisted: Bump to 24.11.0_rc1 (diff)
downloadgentoo-cac9c9da2e4a2720b5932f8be2bcda8026dd90e5.tar.gz
gentoo-cac9c9da2e4a2720b5932f8be2bcda8026dd90e5.tar.bz2
gentoo-cac9c9da2e4a2720b5932f8be2bcda8026dd90e5.zip
media-libs/glycin-loaders: Bump to 1.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/glycin-loaders/Manifest1
-rw-r--r--media-libs/glycin-loaders/glycin-loaders-1.1.2.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/media-libs/glycin-loaders/Manifest b/media-libs/glycin-loaders/Manifest
index 128dae3c9ce4..e5d5822cb726 100644
--- a/media-libs/glycin-loaders/Manifest
+++ b/media-libs/glycin-loaders/Manifest
@@ -1,2 +1,3 @@
DIST glycin-1.1.0.tar.xz 28570152 BLAKE2B 762c8208c5cc8bf6be93a8daa70cd22b1cbd93c60075ccf38225a10c303b2c503bdc1ec2e6efeb85f36f3787b45a6061926e314f44841a583e0e3cb3debc3d48 SHA512 6e4b84dceb8957f0ab6e840dbc60f6c9bb8179fde841075c614a9742282ea578a51a966eb8e7a2482daf631932e8ce5af2f1f41523f376f4d1a0a2069af94631
DIST glycin-1.1.1.tar.xz 28914480 BLAKE2B ef39c3b15e9addd36c6bc7010bbdaf1d5efe7aeaf1a5562217c87310b16efae75b568ae0291f91815238bd4b01747cbc5d3eef26f945f0a21f008904cc382392 SHA512 ce3961b4cbe71739cdf24b985b5a609284e2cdb3869671606cbd0f31c5c99f80da7608f2e29df5a0cc7d7ef0f7bd5926eb3fff993e80cbd8ec03bf321b92b0f0
+DIST glycin-1.1.2.tar.xz 28347232 BLAKE2B fca58f99c8f2096a8d339e32a90435f56547f85715b95a5dd5da754c3d47adae712ea6d0bd9b8f7c6678f9b690837da721203a27ddf461cab16130cc7f3c17d2 SHA512 6eef9d21c5f4a423acea41e82b205de3a4dc0e3a5ce235f6cda4b4bd1052703cb9f4e16095b0927ff9185300c32e8631480d73ac313bda9a58c70122a9b7c3e8
diff --git a/media-libs/glycin-loaders/glycin-loaders-1.1.2.ebuild b/media-libs/glycin-loaders/glycin-loaders-1.1.2.ebuild
new file mode 100644
index 000000000000..0775282f7108
--- /dev/null
+++ b/media-libs/glycin-loaders/glycin-loaders-1.1.2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cargo meson
+
+MY_P=glycin-${PV/_/.}
+DESCRIPTION="Loaders for glycin clients (glycin crate or libglycin)"
+HOMEPAGE="https://gitlab.gnome.org/sophie-h/glycin/"
+SRC_URI="
+ https://download.gnome.org/sources/glycin/$(ver_cut 1-2)/${MY_P}.tar.xz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="|| ( LGPL-2.1+ MPL-2.0 )"
+# Dependent crate licenses
+LICENSE+="
+ Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD-2 BSD GPL-3+ ISC MIT
+ Unicode-DFS-2016
+ || ( LGPL-2.1+ MPL-2.0 )
+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="heif jpegxl svg test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.60:2
+ >=sys-libs/libseccomp-2.5.0
+ heif? ( >=media-libs/libheif-1.17.0:= )
+ jpegxl? ( >=media-libs/libjxl-0.10.0:= )
+ svg? (
+ >=gnome-base/librsvg-2.52.0:2
+ >=x11-libs/cairo-1.17.0
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ >=gui-libs/gtk-4.12.0:4
+ >=media-libs/lcms-2.14:2
+ )
+"
+BDEPEND="
+ test? (
+ sys-apps/bubblewrap
+ sys-apps/dbus
+ )
+"
+
+ECARGO_VENDOR=${S}/vendor
+
+QA_FLAGS_IGNORED="usr/libexec/glycin-loaders/.*"
+
+src_prepare() {
+ default
+
+ # https://gitlab.gnome.org/sophie-h/glycin/-/issues/81
+ sed -i -e '\|/fonts|d' tests/tests.rs || die
+}
+
+src_configure() {
+ local formats=(
+ $(usev heif glycin-heif)
+ $(usev jpegxl glycin-jxl)
+ $(usev svg glycin-svg)
+ glycin-image-rs
+ )
+ local formats_s=${formats[*]}
+ local emesonargs=(
+ -Dprofile=$(usex debug dev release)
+ -Dglycin-loaders=true
+ -Dloaders="${formats_s// /,}"
+ -Dtests=$(usex test true false)
+ -Dlibglycin=false
+ )
+
+ meson_src_configure
+ ln -s "${CARGO_HOME}" "${BUILD_DIR}/cargo-home" || die
+}
+
+src_test() {
+ # tests write to /proc/*/uid_map
+ # apparently, "addpredict /" in Portage breaks it
+ local -x SANDBOX_ON=0
+ meson_src_test
+}