summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Parborg <darkdefende@gmail.com>2021-04-28 02:33:14 +0200
committerSam James <sam@gentoo.org>2021-06-10 00:19:18 +0000
commitd2da0328cf5f3819d72d617577a2122af02fbf6c (patch)
treec2fb24d1e8b8d500da2fa25d576824528ed97c04 /media-libs
parentdev-cpp/pystring: New package (diff)
downloadgentoo-d2da0328cf5f3819d72d617577a2122af02fbf6c.tar.gz
gentoo-d2da0328cf5f3819d72d617577a2122af02fbf6c.tar.bz2
gentoo-d2da0328cf5f3819d72d617577a2122af02fbf6c.zip
media-libs/opencolorio: bump to 2.0.0
Signed-off-by: Sebastian Parborg <darkdefende@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/opencolorio/Manifest1
-rw-r--r--media-libs/opencolorio/opencolorio-2.0.0.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/media-libs/opencolorio/Manifest b/media-libs/opencolorio/Manifest
index c7ac45d7ec95..c961e5e50103 100644
--- a/media-libs/opencolorio/Manifest
+++ b/media-libs/opencolorio/Manifest
@@ -1 +1,2 @@
DIST opencolorio-1.1.1.tar.gz 13828483 BLAKE2B f5642f08db84f2b8da44d0dbf58313c78263496fc6f1f209b93fd303bbf9477033317b44eb8bb2b13a70afa19422f4fa312d52a3fa6598031a2aa50b33bbfccf SHA512 bed722f9ddce1887d28aacef2882debccd7c3f3c0c708d2723fea58a097de9f02721af9e85453e089ffda5406aef593ab6536c6886307823c132aa787e492e33
+DIST opencolorio-2.0.0.tar.gz 9892414 BLAKE2B fdff2e144eadb444624f059f7582ea99d4e2dbd53cad5b89f92d19c7ca9dda2ff9ec4f8c8d00e6ac083da21134f9bc783b297c553a8e7d11936c936e5c41a2f3 SHA512 7110a1a30a5fa64b81d7fc5e33234673aaddbad5e19ce7f21436c590edd7d2ce767650c9a934011a96e53132c030bd0b654fcf93ad79c1bfc8c050762c57f6d0
diff --git a/media-libs/opencolorio/opencolorio-2.0.0.ebuild b/media-libs/opencolorio/opencolorio-2.0.0.ebuild
new file mode 100644
index 000000000000..8ae788457215
--- /dev/null
+++ b/media-libs/opencolorio/opencolorio-2.0.0.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit cmake flag-o-matic python-single-r1
+
+DESCRIPTION="A color management framework for visual effects and animation"
+HOMEPAGE="https://opencolorio.org/"
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/AcademySoftwareFoundation/OpenColorIO.git"
+else
+ SRC_URI="https://github.com/imageworks/OpenColorIO/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/OpenColorIO-${PV}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="cpu_flags_x86_sse2 doc opengl python static-libs test"
+REQUIRED_USE="
+ doc? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-cpp/pystring
+ dev-python/pybind11
+ media-libs/ilmbase
+ >=dev-cpp/yaml-cpp-0.5
+ dev-libs/tinyxml
+ opengl? (
+ media-libs/lcms:2
+ >=media-libs/openimageio-2.2.13.0
+ media-libs/glew:=
+ media-libs/freeglut
+ virtual/opengl
+ )
+ python? ( ${PYTHON_DEPS} )
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-util/cmake-3.16.2-r1
+ virtual/pkgconfig
+ doc? (
+ $(python_gen_cond_dep '
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+# Restricting tests, bugs #439790 and #447908
+RESTRICT="mirror test"
+
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -i -e "s|LIBRARY DESTINATION lib|LIBRARY DESTINATION $(get_libdir)|g" {,src/bindings/python/,src/OpenColorIO/,src/libutils/oiiohelpers/,src/libutils/oglapphelpers/}CMakeLists.txt || die
+ sed -i -e "s|ARCHIVE DESTINATION lib|ARCHIVE DESTINATION $(get_libdir)|g" {,src/bindings/python/,src/OpenColorIO/,src/libutils/oiiohelpers/,src/libutils/oglapphelpers/}CMakeLists.txt || die
+}
+
+src_configure() {
+ # Missing features:
+ # - Truelight and Nuke are not in portage for now, so their support are disabled
+ # - Java bindings was not tested, so disabled
+ # Notes:
+ # - OpenImageIO is required for building ociodisplay and ocioconvert (USE opengl)
+ # - OpenGL, GLUT and GLEW is required for building ociodisplay (USE opengl)
+ local mycmakeargs=(
+ -DOCIO_BUILD_NUKE=OFF
+ -DBUILD_SHARED_LIBS=ON
+ -DOCIO_BUILD_STATIC=$(usex static-libs)
+ -DOCIO_BUILD_DOCS=$(usex doc)
+ -DOCIO_BUILD_APPS=$(usex opengl)
+ -DOCIO_BUILD_PYTHON=$(usex python)
+ -DOCIO_BUILD_JAVA=OFF
+ -DOCIO_USE_SSE=$(usex cpu_flags_x86_sse2)
+ -DOCIO_BUILD_TESTS=$(usex test)
+ -DOCIO_BUILD_GPU_TESTS=$(usex test)
+ -DOCIO_BUILD_FROZEN_DOCS=$(usex doc)
+ -DOCIO_INSTALL_EXT_PACKAGES=NONE
+ )
+
+ # We need this to work around asserts that can trigger even in proper use cases.
+ # See https://github.com/AcademySoftwareFoundation/OpenColorIO/issues/1235
+ append-flags -DNDEBUG
+
+ cmake_src_configure
+}