summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor V. Kovalenko <igor.v.kovalenko@gmail.com>2022-02-19 12:49:30 +0300
committerSam James <sam@gentoo.org>2022-03-08 13:32:19 +0000
commit93b6417f1b55aefc05b91fec7b67eadd32b1f733 (patch)
tree2aa4e2a88378a5d76295ee10fc7b91f2ac40c259 /media-plugins/gst-plugins-sidplay
parentmedia-libs/libfreeaptx: Change to multilib build (diff)
downloadgentoo-93b6417f1b55aefc05b91fec7b67eadd32b1f733.tar.gz
gentoo-93b6417f1b55aefc05b91fec7b67eadd32b1f733.tar.bz2
gentoo-93b6417f1b55aefc05b91fec7b67eadd32b1f733.zip
media-libs/gstreamer: Bump to 1.20.0
Gstreamer 1.20.0 version bump, includes - all existing 1.18.4 plugins except for two dropped upstream (gst-plugins-libmms and gst-plugins-ofa) - libnice-0.1.18 version bump required by gst-plugins-webrtc in 1.20.0 - required multilib change for libldac for new plugin gst-plugins-ldac - required multilib change for libopenaptx and libfreeaptx for new plugin gst-plugins-openaptx As discussed, this change adds a LICENSE to each of gstreamer modules which now require explicit opt-in for (A)GPL plugins for (A)GPL plugins we will not perform explicit license acceptance for affected gstreamer plugin, instead we will rely on a user accepting the license of dependency: - gstreamer change added explicit opt-in https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/1084 - I looked at affected gstreamer plugins and looks like all are correctly license-compatible according to compatibility matrix https://www.gnu.org/licenses/gpl-faq.html#AllCompatibility - if a user is not willing to accept the license of corresponding (A)GPL dependency, such dependency will not be available and affected gstreamer plugin will not be built - Upstream gstreamer team will look into updating/fixing plugin license display available via gst-inspect-1.0 <plugin name> | grep License as currently it is just "GPL" which is not specific enough (should be GPL-2, GPL-2+, GPL-3 etc.) Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-plugins/gst-plugins-sidplay')
-rw-r--r--media-plugins/gst-plugins-sidplay/Manifest1
-rw-r--r--media-plugins/gst-plugins-sidplay/gst-plugins-sidplay-1.20.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-sidplay/Manifest b/media-plugins/gst-plugins-sidplay/Manifest
index d6be25e36be0..354d5431e06b 100644
--- a/media-plugins/gst-plugins-sidplay/Manifest
+++ b/media-plugins/gst-plugins-sidplay/Manifest
@@ -1,2 +1,3 @@
DIST gst-plugins-ugly-1.16.3.tar.xz 899124 BLAKE2B f848c7bbf36cdfca6e3dec4893b9b1bdc363feb697ee7cc89f4c664aa7aa700b76678873e5dae23f277ad99d6034c1e3617d760acc9cd075e0044fae3f4bb88d SHA512 0223f4ceebd1482329cfc7c3faa094d9f3b1d3eaa51eab3ff42da781f0aede8e838221bdc8d1a3ffc43318fb424421447d5548ebaf9ecaf8a290975d178df9ca
DIST gst-plugins-ugly-1.18.4.tar.xz 509920 BLAKE2B a7aec6ac6e5739205c9567072596a8fb6dfcabc2f56ee0800c430c9bfc9549bf7ac75cb65719dadeb84036130d5b58f9be574f2a6531992ee7a8f23e9fb32d16 SHA512 eac02000ac3e0a54a953fe1531cb29bc6bc9913a707d1508905bf64fe0a4ef92f7d01b196259fc217fac8a344f0b2d683dd6d32210ce6b8c0acab08cb3b1322a
+DIST gst-plugins-ugly-1.20.0.tar.xz 502056 BLAKE2B af817568bcc6d24c8fc7ba45382b3a06a50bcd3154aff24d4a430cf2f43dbee784db640517e6c6405a038ed5b3e358c2ae9e0556479c24f20214b77e83edb307 SHA512 a5da400fb59733ec3433ebe40e1fd33e81429d24fbf00dc81c17b7e03e6ca0ce385782b0d3af8d7860c7780b7110872ddcdf0f3f55e60121bcded53d6acdc90d
diff --git a/media-plugins/gst-plugins-sidplay/gst-plugins-sidplay-1.20.0.ebuild b/media-plugins/gst-plugins-sidplay/gst-plugins-sidplay-1.20.0.ebuild
new file mode 100644
index 000000000000..5c95b3e74901
--- /dev/null
+++ b/media-plugins/gst-plugins-sidplay/gst-plugins-sidplay-1.20.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GST_ORG_MODULE=gst-plugins-ugly
+
+inherit gstreamer-meson
+
+DESCRIPTION="Sid decoder plugin for GStreamer"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/libsidplay-1.36.59-r1:1[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dgpl=enabled
+ )
+
+ gstreamer_multilib_src_configure
+}