summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/tap-plugins
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/tap-plugins')
-rw-r--r--media-plugins/tap-plugins/Manifest2
-rw-r--r--media-plugins/tap-plugins/files/tap-plugins-0.7.0-cflags-ldflags.patch118
-rw-r--r--media-plugins/tap-plugins/files/tap-plugins-0.7.3-cflags-ldflags.patch27
-rw-r--r--media-plugins/tap-plugins/metadata.xml29
-rw-r--r--media-plugins/tap-plugins/tap-plugins-0.7.2.ebuild38
-rw-r--r--media-plugins/tap-plugins/tap-plugins-0.7.3.ebuild38
6 files changed, 252 insertions, 0 deletions
diff --git a/media-plugins/tap-plugins/Manifest b/media-plugins/tap-plugins/Manifest
new file mode 100644
index 000000000000..8e111a9604d1
--- /dev/null
+++ b/media-plugins/tap-plugins/Manifest
@@ -0,0 +1,2 @@
+DIST tap-plugins-0.7.2.tar.gz 70961 SHA256 1a484bd8084260448ed3ea6a8edeb61b9e70df9e88036f4b35741fc23be79ee0 SHA512 3cd7605b03c2732f22d7ff79c889b50db4514d232c639cf964d65b2428b8ce6193824e26622ded662cae74351daa38a321bc1b1590035e5fa0fb79bb4620edd0 WHIRLPOOL d965972b45326eddf8a4f33790c6168a1df052949e9ddff08e120ff465c31385a70db7ffbdf99d6f54a3c5d6999d365f08341e05fdd240947419c3be8107ca69
+DIST tap-plugins-0.7.3.tar.gz 70495 SHA256 23ff6b7f5e0968c6afa77bbf3dce74841c1de4a3badfcfad6ccc4c27665b7c2e SHA512 c4e9c93b9fd8afb82067cf3a48ae665843da775c3af6124147ff1f8651d96734a4b961c4c5ea48877b32770e6d0b5a793af32a5cbb6e3b9afd5b59c8b3cc2621 WHIRLPOOL 9f6441b24e5f4d46e4ee22e36a91a39c3931538b1ba6d7886223e0101fe1f87209b9e4c464f21a9e956e9fba76d3bbac11ea2fe78dc200ab4b00718ecc99c94b
diff --git a/media-plugins/tap-plugins/files/tap-plugins-0.7.0-cflags-ldflags.patch b/media-plugins/tap-plugins/files/tap-plugins-0.7.0-cflags-ldflags.patch
new file mode 100644
index 000000000000..088d624dc3d4
--- /dev/null
+++ b/media-plugins/tap-plugins/files/tap-plugins-0.7.0-cflags-ldflags.patch
@@ -0,0 +1,118 @@
+Index: tap-plugins-0.7.0/Makefile
+===================================================================
+--- tap-plugins-0.7.0.orig/Makefile
++++ tap-plugins-0.7.0/Makefile
+@@ -34,9 +34,12 @@ INSTALL_LRDF_DIR = /usr/local/share/lads
+
+ # GENERAL
+
++OPT_CFLAGS = -O3 -fomit-frame-pointer -fstrength-reduce -funroll-loops -ffast-math
+ CC = gcc
+-CFLAGS = -I. -O3 -Wall -fomit-frame-pointer -fstrength-reduce -funroll-loops -ffast-math -c -fPIC -DPIC
+-LDFLAGS = -nostartfiles -shared -Wl,-Bsymbolic -lc -lm -lrt
++CFLAGS = -I. -Wall $(OPT_CFLAGS) -c -fPIC -DPIC
++EXTRA_LDFLAGS =
++LDFLAGS = -nostartfiles -shared -Wl,-Bsymbolic $(EXTRA_LDFLAGS)
++LIBADD = -lc -lm -lrt
+
+ PLUGINS = tap_autopan.so \
+ tap_chorusflanger.so \
+@@ -65,79 +68,79 @@ all: $(PLUGINS)
+
+ tap_tremolo.so: tap_tremolo.c tap_utils.h ladspa.h
+ $(CC) $(CFLAGS) tap_tremolo.c -o tap_tremolo.o
+- $(CC) $(LDFLAGS) -o tap_tremolo.so tap_tremolo.o
++ $(CC) $(LDFLAGS) -o tap_tremolo.so tap_tremolo.o $(LIBADD)
+
+ tap_eq.so: tap_eq.c tap_utils.h ladspa.h
+ $(CC) $(CFLAGS) tap_eq.c -o tap_eq.o
+- $(CC) $(LDFLAGS) -o tap_eq.so tap_eq.o
++ $(CC) $(LDFLAGS) -o tap_eq.so tap_eq.o $(LIBADD)
+
+ tap_eqbw.so: tap_eqbw.c tap_utils.h ladspa.h
+ $(CC) $(CFLAGS) tap_eqbw.c -o tap_eqbw.o
+- $(CC) $(LDFLAGS) -o tap_eqbw.so tap_eqbw.o
++ $(CC) $(LDFLAGS) -o tap_eqbw.so tap_eqbw.o $(LIBADD)
+
+ tap_echo.so: tap_echo.c tap_utils.h ladspa.h
+ $(CC) $(CFLAGS) tap_echo.c -o tap_echo.o
+- $(CC) $(LDFLAGS) -o tap_echo.so tap_echo.o
++ $(CC) $(LDFLAGS) -o tap_echo.so tap_echo.o $(LIBADD)
+
+ tap_reverb.so: tap_reverb.c tap_reverb.h tap_reverb_presets.h tap_utils.h ladspa.h
+ $(CC) $(CFLAGS) tap_reverb.c -o tap_reverb.o
+- $(CC) $(LDFLAGS) -o tap_reverb.so tap_reverb.o
++ $(CC) $(LDFLAGS) -o tap_reverb.so tap_reverb.o $(LIBADD)
+
+ tap_limiter.so: tap_limiter.c tap_utils.h ladspa.h
+ $(CC) $(CFLAGS) tap_limiter.c -o tap_limiter.o
+- $(CC) $(LDFLAGS) -o tap_limiter.so tap_limiter.o
++ $(CC) $(LDFLAGS) -o tap_limiter.so tap_limiter.o $(LIBADD)
+
+ tap_autopan.so: tap_autopan.c tap_utils.h ladspa.h
+ $(CC) $(CFLAGS) tap_autopan.c -o tap_autopan.o
+- $(CC) $(LDFLAGS) -o tap_autopan.so tap_autopan.o
++ $(CC) $(LDFLAGS) -o tap_autopan.so tap_autopan.o $(LIBADD)
+
+ tap_deesser.so: tap_deesser.c tap_utils.h ladspa.h
+ $(CC) $(CFLAGS) tap_deesser.c -o tap_deesser.o
+- $(CC) $(LDFLAGS) -o tap_deesser.so tap_deesser.o
++ $(CC) $(LDFLAGS) -o tap_deesser.so tap_deesser.o $(LIBADD)
+
+ tap_vibrato.so: tap_vibrato.c tap_utils.h ladspa.h
+ $(CC) $(CFLAGS) tap_vibrato.c -o tap_vibrato.o
+- $(CC) $(LDFLAGS) -o tap_vibrato.so tap_vibrato.o
++ $(CC) $(LDFLAGS) -o tap_vibrato.so tap_vibrato.o $(LIBADD)
+
+ tap_rotspeak.so: tap_rotspeak.c tap_utils.h ladspa.h
+ $(CC) $(CFLAGS) tap_rotspeak.c -o tap_rotspeak.o
+- $(CC) $(LDFLAGS) -o tap_rotspeak.so tap_rotspeak.o
++ $(CC) $(LDFLAGS) -o tap_rotspeak.so tap_rotspeak.o $(LIBADD)
+
+ tap_pitch.so: tap_pitch.c tap_utils.h ladspa.h
+ $(CC) $(CFLAGS) tap_pitch.c -o tap_pitch.o
+- $(CC) $(LDFLAGS) -o tap_pitch.so tap_pitch.o
++ $(CC) $(LDFLAGS) -o tap_pitch.so tap_pitch.o $(LIBADD)
+
+ tap_dynamics_m.so: tap_dynamics_m.c tap_dynamics_presets.h tap_utils.h ladspa.h
+ $(CC) $(CFLAGS) tap_dynamics_m.c -o tap_dynamics_m.o
+- $(CC) $(LDFLAGS) -o tap_dynamics_m.so tap_dynamics_m.o
++ $(CC) $(LDFLAGS) -o tap_dynamics_m.so tap_dynamics_m.o $(LIBADD)
+
+ tap_dynamics_st.so: tap_dynamics_st.c tap_dynamics_presets.h tap_utils.h ladspa.h
+ $(CC) $(CFLAGS) tap_dynamics_st.c -o tap_dynamics_st.o
+- $(CC) $(LDFLAGS) -o tap_dynamics_st.so tap_dynamics_st.o
++ $(CC) $(LDFLAGS) -o tap_dynamics_st.so tap_dynamics_st.o $(LIBADD)
+
+ tap_reflector.so: tap_reflector.c tap_utils.h ladspa.h
+ $(CC) $(CFLAGS) tap_reflector.c -o tap_reflector.o
+- $(CC) $(LDFLAGS) -o tap_reflector.so tap_reflector.o
++ $(CC) $(LDFLAGS) -o tap_reflector.so tap_reflector.o $(LIBADD)
+
+ tap_pinknoise.so: tap_pinknoise.c tap_utils.h ladspa.h
+ $(CC) $(CFLAGS) tap_pinknoise.c -o tap_pinknoise.o
+- $(CC) $(LDFLAGS) -o tap_pinknoise.so tap_pinknoise.o
++ $(CC) $(LDFLAGS) -o tap_pinknoise.so tap_pinknoise.o $(LIBADD)
+
+ tap_doubler.so: tap_doubler.c tap_utils.h ladspa.h
+ $(CC) $(CFLAGS) tap_doubler.c -o tap_doubler.o
+- $(CC) $(LDFLAGS) -o tap_doubler.so tap_doubler.o
++ $(CC) $(LDFLAGS) -o tap_doubler.so tap_doubler.o $(LIBADD)
+
+ tap_sigmoid.so: tap_sigmoid.c tap_utils.h ladspa.h
+ $(CC) $(CFLAGS) tap_sigmoid.c -o tap_sigmoid.o
+- $(CC) $(LDFLAGS) -o tap_sigmoid.so tap_sigmoid.o
++ $(CC) $(LDFLAGS) -o tap_sigmoid.so tap_sigmoid.o $(LIBADD)
+
+ tap_tubewarmth.so: tap_tubewarmth.c tap_utils.h ladspa.h
+ $(CC) $(CFLAGS) tap_tubewarmth.c -o tap_tubewarmth.o
+- $(CC) $(LDFLAGS) -o tap_tubewarmth.so tap_tubewarmth.o
++ $(CC) $(LDFLAGS) -o tap_tubewarmth.so tap_tubewarmth.o $(LIBADD)
+
+ tap_chorusflanger.so: tap_chorusflanger.c tap_utils.h ladspa.h
+ $(CC) $(CFLAGS) tap_chorusflanger.c -o tap_chorusflanger.o
+- $(CC) $(LDFLAGS) -o tap_chorusflanger.so tap_chorusflanger.o
++ $(CC) $(LDFLAGS) -o tap_chorusflanger.so tap_chorusflanger.o $(LIBADD)
+
+
+ # OTHER TARGETS
diff --git a/media-plugins/tap-plugins/files/tap-plugins-0.7.3-cflags-ldflags.patch b/media-plugins/tap-plugins/files/tap-plugins-0.7.3-cflags-ldflags.patch
new file mode 100644
index 000000000000..0bfaa5873d23
--- /dev/null
+++ b/media-plugins/tap-plugins/files/tap-plugins-0.7.3-cflags-ldflags.patch
@@ -0,0 +1,27 @@
+Index: tap-plugins-0.7.3/Makefile
+===================================================================
+--- tap-plugins-0.7.3.orig/Makefile
++++ tap-plugins-0.7.3/Makefile
+@@ -35,8 +35,11 @@ INSTALL_LRDF_DIR = /usr/local/share/lads
+ # GENERAL
+
+ CC = gcc
+-CFLAGS = -I. -O3 -Wall -fomit-frame-pointer -fstrength-reduce -funroll-loops -ffast-math -c -fPIC -DPIC
+-LDFLAGS = -nostartfiles -shared -Wl,-Bsymbolic -lc -lm -lrt
++OPT_CFLAGS = -O3 -fomit-frame-pointer -fstrength-reduce -funroll-loops -ffast-math
++CFLAGS = -I. -Wall $(OPT_CFLAGS) -c -fPIC -DPIC
++EXTRA_LDFLAGS =
++LDFLAGS = -nostartfiles -shared -Wl,-Bsymbolic $(EXTRA_LDFLAGS)
++LIBADD = -lc -lm -lrt
+ MODULES = $(wildcard *.c)
+
+ all: $(MODULES:%.c=%.so)
+@@ -51,7 +54,7 @@ tap_dynamics_st.o: tap_dynamics_presets.
+ $(CC) $(CFLAGS) $< -o $@
+
+ %.so: %.o
+- $(CC) -o $@ $< $(LDFLAGS)
++ $(CC) $(LDFLAGS) -o $@ $< $(LIBADD)
+
+ # OTHER TARGETS
+
diff --git a/media-plugins/tap-plugins/metadata.xml b/media-plugins/tap-plugins/metadata.xml
new file mode 100644
index 000000000000..a4924a938c0e
--- /dev/null
+++ b/media-plugins/tap-plugins/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proaudio</herd>
+ <longdescription>
+TAP-plugins is short for Tom's Audio Processing plugins. It is a bunch of
+LADSPA plugins for digital audio processing, intended for use in a
+professional DAW environment such as Ardour. These plugins should compile
+and run on any recent (that is, not seriously outdated) GNU/Linux system.
+They don't require any special libraries besides the standard GNU C and math
+libraries, which are expected to be provided on the machine used for
+compiling.
+
+The audio processing algorithms done by TAP-plugins are coded to be
+independent of the actual sample rate. The sample rate is always a parameter
+during computations. The plugins have been tested with sample rates 44.1 kHz
+and 96 kHz, as the author uses these values in his studio. Please note that
+although all plugins should be essentially functional at virtually any
+sample rate, the audio fidelity depends slightly on the actual sample rate
+used. Higher sample rate is better, of course. This means that an equalizer
+or reverberator plugin will produce higher quality output, and will sound a
+bit smoother at 96 kHz compared to, say, 44.1 kHz. This is a natural effect
+that results from the fundamental properties of digital signal processing,
+but you should be aware of it nevertheless.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">tap-plugins</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-plugins/tap-plugins/tap-plugins-0.7.2.ebuild b/media-plugins/tap-plugins/tap-plugins-0.7.2.ebuild
new file mode 100644
index 000000000000..3e2c9d2b31cf
--- /dev/null
+++ b/media-plugins/tap-plugins/tap-plugins-0.7.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit multilib toolchain-funcs eutils
+
+IUSE=""
+
+DESCRIPTION="TAP LADSPA plugins package. Contains DeEsser, Dynamics, Equalizer, Reverb, Stereo Echo, Tremolo"
+HOMEPAGE="http://tap-plugins.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+DEPEND="media-libs/ladspa-sdk"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.7.0-cflags-ldflags.patch"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) OPT_CFLAGS="${CFLAGS}" EXTRA_LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dodoc README CREDITS
+ insinto /usr/$(get_libdir)/ladspa
+ insopts -m0755
+ doins *.so
+ insinto /usr/share/ladspa/rdf
+ insopts -m0644
+ doins *.rdf
+}
diff --git a/media-plugins/tap-plugins/tap-plugins-0.7.3.ebuild b/media-plugins/tap-plugins/tap-plugins-0.7.3.ebuild
new file mode 100644
index 000000000000..e71ce1adc424
--- /dev/null
+++ b/media-plugins/tap-plugins/tap-plugins-0.7.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit multilib toolchain-funcs eutils
+
+IUSE=""
+
+DESCRIPTION="TAP LADSPA plugins package. Contains DeEsser, Dynamics, Equalizer, Reverb, Stereo Echo, Tremolo"
+HOMEPAGE="http://tap-plugins.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+DEPEND="media-libs/ladspa-sdk"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.7.3-cflags-ldflags.patch"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) OPT_CFLAGS="${CFLAGS}" EXTRA_LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dodoc README CREDITS
+ insinto /usr/$(get_libdir)/ladspa
+ insopts -m0755
+ doins *.so
+ insinto /usr/share/ladspa/rdf
+ insopts -m0644
+ doins *.rdf
+}