summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2018-07-06 15:14:27 +0200
committerJoerg Bornkessel <hd_brummy@gentoo.org>2018-07-06 15:14:27 +0200
commitada3ec53323baed59a476820958dfb753caf5e0e (patch)
tree5fdc81cedfd60557801588d3cd55af0b2b206022 /media-plugins/vdr-live
parentdev-libs/libuv: Fix unexpected ABI change (bug #659872). (diff)
downloadgentoo-ada3ec53323baed59a476820958dfb753caf5e0e.tar.gz
gentoo-ada3ec53323baed59a476820958dfb753caf5e0e.tar.bz2
gentoo-ada3ec53323baed59a476820958dfb753caf5e0e.zip
media-plugins/vdr-live: version bump, fixed deprecated eapi
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'media-plugins/vdr-live')
-rw-r--r--media-plugins/vdr-live/Manifest1
-rw-r--r--media-plugins/vdr-live/files/confd-2.329
-rw-r--r--media-plugins/vdr-live/files/rc-addon-2.3.sh30
-rw-r--r--media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r1.ebuild4
-rw-r--r--media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r2.ebuild4
-rw-r--r--media-plugins/vdr-live/vdr-live-2.3.1.ebuild99
6 files changed, 163 insertions, 4 deletions
diff --git a/media-plugins/vdr-live/Manifest b/media-plugins/vdr-live/Manifest
index f260557b6394..0178f3d83f6a 100644
--- a/media-plugins/vdr-live/Manifest
+++ b/media-plugins/vdr-live/Manifest
@@ -1 +1,2 @@
+DIST release_2-3-1.tar.bz2 703327 BLAKE2B 70724894a4abf2f94d682602d722b3d015cefefa7c9daf2dae35fc84bff1d950539c916d6d97e39565e87e8e7d841277ad14e137238026b25f73b1b288fa18f5 SHA512 f943c2aa477ca943b2015eb0b49a650e5c9e5cc124549b68d36b56a0ae6344a8d32ac3c4f213ab3cb91794ae569d3ed14a84168f45bf395e90536992078bce41
DIST vdr-live-0.3.0_p20130504.tar.bz2 6348021 BLAKE2B 64567a037dd283d005727b993053609e7c46784de67bcbd9afb4f68edd03cec494e6eca6c497ac578928de92c1d21b2519867c014cfd11ace79e957fc5d487d1 SHA512 7a238a4567f90448b7813366dbdb5112ab98079fd5a2c9d59d09273853fd62ad520ca9ad373704a8888eb7c25119772421fe998d87069647c40d6d2d869e09c1
diff --git a/media-plugins/vdr-live/files/confd-2.3 b/media-plugins/vdr-live/files/confd-2.3
new file mode 100644
index 000000000000..cb1dce04dfb5
--- /dev/null
+++ b/media-plugins/vdr-live/files/confd-2.3
@@ -0,0 +1,29 @@
+# configuration of media-plugins/vdr-live
+
+# for people who want more secure
+# with ssl access.
+# on usage, you have to install vdr-live
+# with USE="ssl"
+#
+# SSL ADDRESS --> https://<your-ip>:8443/
+#
+# allowed values: yes no
+# default: no
+#LIVE_USE_SSL="yes"
+
+# default given portnumber
+# only changes needed on problems
+#
+#LIVE_PORT="8008"
+#LIVE_SSL_PORT="8443"
+
+# bind to these IP addresses
+# default, your IP will automaticly detected
+#
+LIVE_BIND_IPS="127.0.0.1"
+
+# for people who have epgimges
+# default: /var/cache/vdr/epgimges
+#
+# set this to your own path, if needed
+#EPGIMAGES_DIR=" "
diff --git a/media-plugins/vdr-live/files/rc-addon-2.3.sh b/media-plugins/vdr-live/files/rc-addon-2.3.sh
new file mode 100644
index 000000000000..1372e09d56f0
--- /dev/null
+++ b/media-plugins/vdr-live/files/rc-addon-2.3.sh
@@ -0,0 +1,30 @@
+#
+# zzam@g.o
+# hd_brummy@g.o
+
+EPGIMAGES_DIR="/var/cache/vdr/epgimages"
+
+plugin_pre_vdr_start() {
+ if [ "${LIVE_USE_SSL:=no}" = "yes" ]; then
+ if [ -n "${LIVE_SSL_PORT}" ]; then
+ add_plugin_param "-s ${LIVE_SSL_PORT}"
+ fi
+
+ add_plugin_param "--cert=/etc/vdr/plugins/live/live.pem"
+ add_plugin_param "--key=/etc/vdr/plugins/live/live-key.pem"
+
+ else
+ if [ -n "${LIVE_PORT}" ]; then
+ add_plugin_param "-p ${LIVE_PORT}"
+ fi
+ fi
+
+ if [ -d ${EPGIMAGES_DIR} ]; then
+ add_plugin_param "--epgimages=${EPGIMAGES_DIR}"
+ fi
+
+ local ip
+ for ip in ${LIVE_BIND_IPS:=`hostname -i`}; do
+ add_plugin_param "-i ${ip}"
+ done
+}
diff --git a/media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r1.ebuild b/media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r1.ebuild
index 41c00b51519b..6041faafd99e 100644
--- a/media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r1.ebuild
+++ b/media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit vdr-plugin-2 ssl-cert
diff --git a/media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r2.ebuild b/media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r2.ebuild
index 9d7f6bdbaf5d..0dbcc0a04730 100644
--- a/media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r2.ebuild
+++ b/media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit vdr-plugin-2 ssl-cert
diff --git a/media-plugins/vdr-live/vdr-live-2.3.1.ebuild b/media-plugins/vdr-live/vdr-live-2.3.1.ebuild
new file mode 100644
index 000000000000..ef19ad4ee495
--- /dev/null
+++ b/media-plugins/vdr-live/vdr-live-2.3.1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vdr-plugin-2 ssl-cert
+
+MY_P="release_2-3-1"
+
+DESCRIPTION="VDR Plugin: Web Access To Settings"
+HOMEPAGE="http://live.vdr-developer.org"
+SRC_URI="https://projects.vdr-developer.org/git/vdr-plugin-live.git/snapshot/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pcre ssl"
+
+DEPEND="media-video/vdr
+ >=dev-libs/tntnet-2.2.1[ssl=]
+ >=dev-libs/cxxtools-2.2.1
+ pcre? ( >=dev-libs/libpcre-8.12[cxx] )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+VDR_CONFD_FILE="${FILESDIR}/confd-2.3"
+VDR_RCADDON_FILE="${FILESDIR}/rc-addon-2.3.sh"
+
+make_live_cert() {
+ # TODO: still true?
+ # ssl-cert eclass creates a "invalid" cert, create our own one
+ local base=$(get_base 1)
+ local keydir="/etc/vdr/plugins/live"
+
+ SSL_ORGANIZATION="${SSL_ORGANIZATION:-VDR Plugin Live}"
+ SSL_COMMONNAME="${SSL_COMMONNAME:-`hostname -f`}"
+
+ echo
+ gen_cnf || return 1
+ echo
+ gen_key 1 || return 1
+ gen_csr 1 || return 1
+ gen_crt 1 || return 1
+ echo
+
+ install -d "${ROOT}${keydir}"
+ install -m0400 "${base}.key" "${ROOT}${keydir}/live-key.pem"
+ install -m0444 "${base}.crt" "${ROOT}${keydir}/live.pem"
+ chown vdr:vdr "${ROOT}"/etc/vdr/plugins/live/live{,-key}.pem
+}
+
+src_prepare() {
+ default
+
+ # remove untranslated language files
+ rm "${S}"/po/{ca_ES,da_DK,el_GR,et_EE,hr_HR,hu_HU,nl_NL,nn_NO,pt_PT,ro_RO,sl_SI,tr_TR}.po
+
+ vdr-plugin-2_src_prepare
+
+ if ! use pcre; then
+ sed -i "s:^HAVE_LIBPCRECPP:#HAVE_LIBPCRECPP:" Makefile || die
+ fi
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ insinto /usr/share/vdr/plugins/live
+ doins -r live/*
+
+ fowners -R vdr:vdr /usr/share/vdr/plugins/live
+}
+
+pkg_postinst() {
+ vdr-plugin-2_pkg_postinst
+
+ elog "To be able to use all functions of vdr-live"
+ elog "you should emerge and enable"
+ elog "media-plugins/vdr-epgsearch to search the EPG,"
+ elog "media-plugins/vdr-streamdev for Live-TV streaming"
+
+ elog "The default username/password is:"
+ elog "\tadmin:live"
+
+ if use ssl ; then
+ if path_exists -a "${ROOT}"/etc/vdr/plugins/live/live.pem; then
+ einfo "found an existing SSL cert, to create a new SSL cert, run:\n"
+ einfo "emerge --config ${PN}"
+ else
+ einfo "No SSL cert found, creating a default one now"
+ make_live_cert
+ fi
+ fi
+}
+
+pkg_config() {
+ make_live_cert
+}