summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-09-16 17:48:43 -0400
committerCraig Andrews <candrews@gentoo.org>2020-09-16 17:56:19 -0400
commit049b68ebe4caab1e63847b51dc4fdca2d23a487c (patch)
treef2d2882b0b38df5ff65cd51db50de8a25a7d9e13 /media-plugins
parentmedia-plugins/kodi-visualization-waveform: 4.4.0 version bump (diff)
downloadgentoo-049b68ebe4caab1e63847b51dc4fdca2d23a487c.tar.gz
gentoo-049b68ebe4caab1e63847b51dc4fdca2d23a487c.tar.bz2
gentoo-049b68ebe4caab1e63847b51dc4fdca2d23a487c.zip
media-plugins/kodi-pvr-nextpvr: 7.0.0 version bump
Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/kodi-pvr-nextpvr/Manifest1
-rw-r--r--media-plugins/kodi-pvr-nextpvr/kodi-pvr-nextpvr-7.0.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/media-plugins/kodi-pvr-nextpvr/Manifest b/media-plugins/kodi-pvr-nextpvr/Manifest
index e2b87cea2ee1..e9a216f460e0 100644
--- a/media-plugins/kodi-pvr-nextpvr/Manifest
+++ b/media-plugins/kodi-pvr-nextpvr/Manifest
@@ -6,3 +6,4 @@ DIST kodi-pvr-nextpvr-3.3.21.tar.gz 130510 BLAKE2B edbaa2e1910d8f601673c55be264a
DIST kodi-pvr-nextpvr-6.0.5.tar.gz 146642 BLAKE2B 76f06dc933f3b23ff16da2faa9726a7c7120fb54bc10883787669bfa0f24c9998849c44237727160b2b96d3ae5375de8e6cc64c96b9bb430f9eb634e3d0fa4c5 SHA512 67c43f6a781d233a8c157d3a8718a9bf106526ca6844a1296f17510171c5e76be74d1884d04bfa63ed7dcaf4ce683c1b03d71be64bc40c3cc335114532845f5f
DIST kodi-pvr-nextpvr-6.2.0.tar.gz 144852 BLAKE2B 11eca61606db5cbab753a651fdfcf8460a6e7910870838e37c5dcdb723ebe8d19b6920d20439ce185a3ba1e6e42c4fe5b3932f09b8b7f016f355d3d80e382316 SHA512 60473dfab1306666bcfa1ece7944143f144506204331593de2a6e21bc0db215348c48ff764698af7032caf0083485bf251a10b8878d0a0faf85e0c95878a85e5
DIST kodi-pvr-nextpvr-6.2.1.tar.gz 144925 BLAKE2B c1021517c1c305fb71453aeac1c7bda5c31ebe2e0175fc64ac72c5f76dd0eeb40d1c851388dea094f8eb15c53f163b2f02cad61cfd76004c64e42f7333b7a61d SHA512 a9e3075569ec24639cd80388c35cac6b9632a2c2cf622be46abbefa69e91847d37f8afe98224b7a543a1ed78b2204bb6b8f243a6e5db08630cd904b19164d703
+DIST kodi-pvr-nextpvr-7.0.0.tar.gz 145031 BLAKE2B 01d8583d74111dfcb59a139987dc30cc900a41742ea28d4a0fcec11864cb6fc505dd200cf7b61c9dc3d7338ac500d014cc6a312ed8b26be6387604a7969aa9d1 SHA512 b7ede2d9f2a384816c48c19078583aa996f8d08671842444abc93a02e7d3cea9669deb67c26429aa68d3875b6644c29f467bc925768a336916b6b6a7d0894cc9
diff --git a/media-plugins/kodi-pvr-nextpvr/kodi-pvr-nextpvr-7.0.0.ebuild b/media-plugins/kodi-pvr-nextpvr/kodi-pvr-nextpvr-7.0.0.ebuild
new file mode 100644
index 000000000000..141349d2e0d9
--- /dev/null
+++ b/media-plugins/kodi-pvr-nextpvr/kodi-pvr-nextpvr-7.0.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake kodi-addon
+
+DESCRIPTION="Kodi's NextPVR client addon"
+HOMEPAGE="https://github.com/kodi-pvr/pvr.nextpvr"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/kodi-pvr/pvr.nextpvr.git"
+ inherit git-r3
+ ;;
+*)
+ CODENAME="Matrix"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/kodi-pvr/pvr.nextpvr/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/pvr.nextpvr-${PV}-${CODENAME}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-19*
+ =dev-libs/libplatform-2*
+ dev-libs/tinyxml
+ "
+
+RDEPEND="
+ ${DEPEND}
+ "