summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-11-12 12:28:53 -0500
committerMatt Turner <mattst88@gentoo.org>2022-11-12 12:28:53 -0500
commitdb3c29d2f8eea9f1e6088aa3d5b17de779920929 (patch)
tree45178bcfcda3bb6d8d2e28516f0098febfed6de0 /media-plugins
parentmedia-libs/zimg: Drop old versions (diff)
downloadgentoo-db3c29d2f8eea9f1e6088aa3d5b17de779920929.tar.gz
gentoo-db3c29d2f8eea9f1e6088aa3d5b17de779920929.tar.bz2
gentoo-db3c29d2f8eea9f1e6088aa3d5b17de779920929.zip
media-plugins/live: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/live/Manifest1
-rw-r--r--media-plugins/live/live-2021.05.22.ebuild108
2 files changed, 0 insertions, 109 deletions
diff --git a/media-plugins/live/Manifest b/media-plugins/live/Manifest
index 6051c4f84a76..d2222f35eb26 100644
--- a/media-plugins/live/Manifest
+++ b/media-plugins/live/Manifest
@@ -1,2 +1 @@
-DIST live.2021.05.22.tar.gz 682749 BLAKE2B 38663f8c5dbd8cccf4e5cfe685b0eb393559195eba852fcdf6c38c7be936948d2727da91e829aedbde08eab6edb6082533d14061edfcf125d82c925bffdb9f90 SHA512 4021cbdaffb48b9b361e931fa71f89db1e116fe8c4e57df78d54493b111a8c6249431cc418a20352a45a75ef240712609eed3aa7468c6049996dd2451ae2941c
DIST live.2021.08.24.tar.gz 683337 BLAKE2B fabc24498cc5b23b43f11303598b770a84036d0f835a04284bc9fc4f2525d39f4e846e8eb16f724136f9b0caad20cb3dc55b14218fc0ec764822fa22a018642d SHA512 f776e43a9b0792fd41e43f3c06e48f5d766c405d6af4ed5ddac108723f222c844ec5dbe29701b62dff760fbed777935ffc9149080b45d7a7b4c655a7f1fe6dae
diff --git a/media-plugins/live/live-2021.05.22.ebuild b/media-plugins/live/live-2021.05.22.ebuild
deleted file mode 100644
index 951d89f4c0b2..000000000000
--- a/media-plugins/live/live-2021.05.22.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="Libraries for standards-based RTP/RTCP/RTSP multimedia streaming"
-HOMEPAGE="http://www.live555.com/"
-SRC_URI="http://www.live555.com/liveMedia/public/${P/-/.}.tar.gz"
-
-LICENSE="LGPL-2.1"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
-IUSE="ssl"
-
-BDEPEND="virtual/pkgconfig"
-DEPEND="
- ssl? (
- dev-libs/openssl:0=
- )
-"
-RDEPEND="${DEPEND}"
-
-DOCS=( "live-shared/README" )
-
-# Alexis Ballier <aballier@gentoo.org>, Sam James <sam@gentoo.org>
-# Be careful, bump this everytime you bump the package and the ABI has changed.
-# If you don't know, ask someone.
-# You may wish to use a site like https://abi-laboratory.pro/index.php?view=timeline&l=live555
-LIVE_ABI_VERSION=9
-SLOT="0/${LIVE_ABI_VERSION}"
-
-S="${WORKDIR}/live"
-
-src_prepare() {
- default
-
- cp "${FILESDIR}/config.gentoo-so-r3" "${S}/config.gentoo-so-r1" || die
-
- # This is all legacy stuff which needs to be cleaned up
- case ${CHOST} in
- *-solaris*)
- sed -i \
- -e '/^COMPILE_OPTS /s/$/ -DSOLARIS -DXLOCALE_NOT_USED/' \
- -e '/^LIBS_FOR_CONSOLE_APPLICATION /s/$/ -lsocket -lnsl/' \
- live/config.gentoo-so-r1 \
- || die
- ;;
- *-darwin*)
- sed -i \
- -e '/^COMPILE_OPTS /s/$/ -DBSD=1 -DHAVE_SOCKADDR_LEN=1/' \
- -e '/^LINK /s/$/ /' \
- -e '/^LIBRARY_LINK /s/=.*$/= $(CXX) -o /' \
- -e '/^LIBRARY_LINK_OPTS /s:-shared.*$:-undefined suppress -flat_namespace -dynamiclib -install_name '"${EPREFIX}/usr/$(get_libdir)/"'$@:' \
- -e '/^LIB_SUFFIX /s/so/dylib/' \
- live/config.gentoo-so-r1 \
- || die
- ;;
- esac
-}
-
-src_configure() {
- # This ebuild uses its own build system
- # We don't want to call ./configure or anything here.
- # The only thing we can do is honour the user's SSL preference.
- if use ssl ; then
- sed -i 's/-DNO_OPENSSL=1//' "${S}/config.gentoo-so-r1" || die
- fi
-
- # Bug 718912
- tc-export CC CXX
-
- # And defer to the scripts that upstream provide.
- ./genMakefiles gentoo-so-r1 || die
-}
-
-src_compile() {
- export suffix="${LIVE_ABI_VERSION}.so"
- local link_opts="$(usex ssl "$($(tc-getPKG_CONFIG) --libs libssl libcrypto)" '') -L. ${LDFLAGS}"
- local lib_suffix="${suffix#.}"
-
- einfo "Beginning shared library build"
- emake LINK_OPTS="${link_opts}" LIB_SUFFIX="${lib_suffix}"
-
- for i in liveMedia groupsock UsageEnvironment BasicUsageEnvironment ; do
- cd "${S}/${i}" || die
- ln -s "lib${i}.${suffix}" "lib${i}.so" || die
- done
-
- einfo "Beginning programs build"
- for i in proxyServer mediaServer ; do
- cd "${S}/${i}" || die
- emake LINK_OPTS="${link_opts}"
- done
-}
-
-src_install() {
- for library in UsageEnvironment liveMedia BasicUsageEnvironment groupsock ; do
- dolib.so "${S}/${library}/lib${library}.${suffix}"
- dosym "lib${library}.${suffix}" "/usr/$(get_libdir)/lib${library}.so"
-
- insinto /usr/include/"${library}"
- doins "${S}/${library}"/include/*h
- done
-
- dobin "${S}"/mediaServer/live555MediaServer
- dobin "${S}"/proxyServer/live555ProxyServer
-}